Build 99 HQ Player connection problems

Still can’t get more than 5 seconds of audio without a disconnect as far as DSD playback is concerned.
Systems is as follows: 2012 Mac Mini Configured by YFS, Quad Core Processor, SSD Drive, 16gb Memory. HQ Player to an Auralic Vega Dac via Light Harmonic 10g Split USB Cable, Dual Regens.
I get no indication of CPU Spikes or low Memory in System Monitor.
The audio just keeps going in and out. Have tried all the different suggestions.
DSD 64 is a bit more stable, 128 is a complete mess. Tidal is also fine.
Roon stand alone all good, HQ Player stand alone all good.
Wish I could figure this out.

No quite fixed on my end. Occasionally if I stop a track and start it up, it looks like the track is playing but I get no sound. If I hit skip back or forward, the sound starts. So I don’t have to use the break link anymore. I’ve also seen it playing a track and start the new one and got no sound on that track until I skipped back to beginning.

So this problem is a little different than before. Only had issue when skipping to next track or another track while track was playing in previous build. While I don’t like bugs, I prefer this issue over the last since I don’t have manually go in and hit break link. I can just use keyboard play control to start back up.

I also noticed this happens when skipping to next track as well. But the consistent part is the track always looks like it’s playing with progress bar moving and skipping back fixes issue with sound starting back up.

What you’re describing sounds very much like a performance issue–not all performance issues show up in Activity Monitor. The audio going in and out symptom is classic performance stuff, as is the fact that simpler formats are giving you less trouble than more demanding formats.

This is a better experiment: Try turning off all HQPlayer filters, then see how playback works with a few formats of different complexity (44.1k, DSD128 perhaps).

Then turn the filter settings back up, gradually, and see when problems appear.

Roon is doing almost nothing when playing to HQPlayer–we are just reading the file and passing the bits along. HQPlayer is doing very demanding processing to the audio. Assuming I’m right about this being a performance issue, there is a better than even chance that this is not going to be a Roon problem. I hope you are able to sort it out.

EDIT: Also, can you confirm your HQPlayer version? I suggest trying both 3.12.0 and 3.13b2 to see if you get different results.

@Mike_Scheinkman, can you confirm your HQPlayer version? I suggest trying both 3.12.0 and 3.13b2 to see if you get different results.

If Roon is in the playing state, then we have passed a URL to HQPlayer and requested that playback start. Maybe something is going wrong in the communication between HQPlayer and your DAC, or it’s having a hiccup while starting the stream, or something.

Does anyone have a link to HQPlayer 3.13b2?

Found it:

I’ll report back whether this fixed it.

I doubt it’s a performance issue since I’m only using 88200 upsampling with minphaseFIR and NS4 filters. Also on latest 27" iMac 3.2 core i5 with 24gb ram. I’ll update HQPlayer once I find the link.

So Im still having this problem. I just hit skip to next track and no sound but progress bar is moving and in HQPlayer I still see time moving and stream active.

Under Time I see song: Room
Limited: 17 What does Limited mean? Seems to always change.

Strange! With me it is no problem when I skip to next track with the new release (99). I had the trouble as you described with the former relaese (84).

Intel NUC I5 4250U
Roon 64 (99)
PS Audio Directstream Dac

Page 12 of HQP Manual, Section 2.15 & 2.16 would be the place to start.

Limiting is to prevent signal clipping

Hi Brian,
Thanks for chiming in. First off I absolutely love Roon. It is a lot of fun to use.
Getting back to the HP integration, at the time of my initial email I was using 3.12, although I thought I was using the beta. I proceeded to download 3.13b2
And started messing around. I was not sure how to turning off all the filtering in HQ, PCM defaults allow your to select none but not DSD/DSF.
Tried Wave PCM 44.1, Flac 24/96, Native DSD 64… These all played for the most part without an issue. Note: non DSD files are being unconverted to DSD 128 on the fly as well.
When I go to Native DSD 128, this is where I have constant disconnects and audio dropouts.
I decided to replace my Main DSD library which are AIFF files up converted to DSD using the AuInventory Sofrware with my original AIFF folder and listening as I type this, had one hicup across 4 tracks, way better than the DSD 128 files.
I also have DSD tracks from Acoustic Sounds as well as SACD Rips using a PS3. All DSD 128 issues are across the board be it the up converted or from Acoustic Sounds.
Thanks for your help!

Update: listened to a complete album, had a total of maybe four audio dropouts. None of which required my doing anything to recover.

I’m sorry if I sound like a broken record, but dropouts are virtually always a function of performance. The fact that more difficult (DSD128) tracks are causing more of them than simpler PCM content is another piece of evidence in that column. The more I hear from you, the more this is sounding like a performance issue and not a bug.

I don’t think there is anything that we can do for you. Roon is really just a middle-man between your drive/NAS and HQPlayer’s input section. We pass data along as quickly as possible–dropouts tell me that HQPlayer isn’t getting the processed data to the driver quickly enough, or the driver isn’t getting data to the sound card quickly enough.

So by performance you mean my Mac Mini, both Roon and HQ Player handle DSD 128 on their own without issue.
So what you are saying is the mini is not handling having both programs running at the same time when it comes to DSD 128.

I suspect that HQP to NAA communication is extremely sensitive to network quality. I made some network changes and dropouts seems to have stopped.

It doesn’t make sense that the Roon HQ Player combination can upsample to DSD 128 but not deal with Native DSD 128 files.
Maybe it is on the Player end of things.
I appreciate the input, thanks.
Hope to get it figured out.

I’m now running Roon build 99 plus HQPlayer 3.13b2 and all playback issues are fixed as far as I can tell. I have been playing a combination of Tidal, 16/44CD, 24/192, DXD and DSD64 all upsampled to DSD128 and then playing all PCM upsampled to DXD(384) PCM resolution and no dropouts, stuttering or anything!!! I have noticed a couple of times where as I switched tracks, the track seemed to be restarting (the red arrow on the trackbar moves quickly back and forth), but other than the slightest delay, not a single playback error in several hours of playing. Way to go Roon and Jussi!

Now, if there was just a way to get the bar that allows me to choose between PCM and SDM and between resolutions in HQP to show in Roon, I’d be in heaven… Right now, I have to run to a different part of the house where the Roon Core is to make those adjustments.

Next, I need to figure out how to get this combo to upsample to and play DSD256 (which my Oppo BDP-105D is supposed to do, but I must have something configured wrong in HQP.

One setting I recently changed that seems to have made a big difference with stuttering and dropouts (at least for me), was to enable Jumbo Frames on my PCIe Controller. I had previously upgraded my cabling to Cat& and my switch to Gigbit Ethernet, but hadn’t made the Jumbo frames change.

I seemed have fixed the DSD 128 audio dropout issue…
Running OS X Mavericks on my mini, decided to update to Yosemite…
Getting continuous playback, no audio glitches. I did get the disconnect issue at the end of one of the tracks like others have reported but ecstatic that it is now a viable scenario. Very Happy!!!

NAA running on OS X: make sure you dac is selected as output device in Audio Midi settings. No sync losses between songs now.

Try TeamViewer. No need to run between rooms for this type of thing.