C368 with BluOS MDC card getting "killed" by roon

Good morning dear Roonies and @support

My BluOS MDC card behaves strangely the past few weeks. When I play something with the BluOS app, everything works perfectly fine. But when I play something with Roon the track either won’t start (Roon lost Control over the audio device, and is then not visible any more for the BluOS app and Roon and I have to reset everything to get it going again) or it plays a few tracks and getting killed then (Roon lost Control of the Audio device)

Roon runs on a NUC with ROCK, connected by Ethernet
C368 connected by Ethernet
Netgear Nighthawk Router

Both the Flex2 and the Powernode2 (all connected by Ethernet) work perfectly fine, both with BluOS and Roon.

Any ideas how to troubleshoot that strange behavior?

C368 runs on the latest firmware, 1.71, BluOS MDC card runs on the latest firmware as well)

Thank you so much in advance!

Best regards from Switzerland,


If you have three instances, two of which work OK then the people best placed to offer focussed advice is Nad. If you haven’t already done so I’d approach them too.

1 Like

Does is happen only when you play MQA files from Tidal (there is an issue with this) or at other times as well?

Happens with Local Files and streaming from Qobuz

Interesting, and it looks like everything is connected by ethernet, so it’s not a wifi issue, where I have found BluOs performance to be less than stellar.

When I had my C388 connected directly to my core (i.e. no wifi), it worked perfectly, so I am not sure it is a BluOs issue or Roon issue.

Is the C368 connected directly to the router? Are there any ethernet switches involved, as I know that managed switches have caused issues in the past.

Thanks all for your inputs, I worked it out:

The problem was caused by a faulthy LAN cable…