Cambridge Audio CXN no longer working on USB

I have been running Roon on a ROCK using USB V2 connection to a Cambridge Audio CXN successfully for 6 months.
ROCK v1.0 (Build158) NUC icore7 as per recommended build
Roon server V1.5 (Build 320)
Everything worked perfectly sending bit perect audio to my device at up to 192 khz until recently.
Now I am able to see the USB connection in Roon. If I reselect USB 2.0 on the CXN and rescan for devices it briefly shows up before disappearing.If I select USB 1.0 on the CXN it can be configured but when I select an album or playlist it skips through the songs without playing any. Connecting to the CXN via the airplay link works fine (connection via ethernet).
Cambridge Audio updated the firmware around a month ago but things worked fine after that. Roon is obviously updating regularly so I’m not sure if it is a combination of updates that have caused the failure.
I have rebooted both devices many times
Tried to load the log but doesn’t except text files?
Help to get things working again would be great

Let’s tag @support to follow up with you.

A post was split to a new topic: Pioneer N-70AE no longer working on USB

Thanks Carl
Tried the tag link but I got an error. Just not my day!

The tag Carl used was to send alerts to the Support team to visit this thread. Nothing you need to do with it.

1 Like

Hi @Geoff_Bulte ----- Thank you for the report and sharing this observation you have made with us. The insight is appreciated and sorry to hear of the troubles.

Moving forward, to help aide in our understanding of this behavior you are experiencing may I very kindly ask you for the following:

  • While it may seem elementary, during your troubleshooting of this behavior have you…

    • Rebooted the NUC and the endpoint?
    • Tested with another USB cable?
    • Tried another DAC to see if it exhibits the same behavior?

Additionally, I would like to enable diagnostics on your account so our team can have a closer look into this behavior you are experiencing. However, before I enable this feature can you please perform the following:

Timestamp #1

“If I reselect USB 2.0 on the CXN and rescan for devices it briefly shows up before disappearing.”

  • Please reproduce this issue and note the time when it occurs. In your follow up please list this data point as the following: “Tried USB 2.0 @ x:xx pm/am”

Timestamp #2

"If I select USB 1.0 on the CXN it can be configured but when I select an album or playlist it skips through the songs without playing any.

  • Please reproduce this issue and not the time when it occurs. In your follow up please list this data point as the following: “Selected USB 1.0 @ x:xx pm/am” and “Tried to play - album x @ x:xx pm/am”


Thanks Eric
I have rebooted both devices and did again today.
I replaced the cable and the problem persists
I don’t have another DAC but it works on my Denon receiver and the CXN via airplay but I can’t test the USB function on another machine
Tried USB 2.0 @ 6:29 pm (NZ time)
Tried USB 1.0 @ 6:30 pm and tried to play
Tried USB 2.0 @ 6:40 pm
Tried to play - album Raising Sand@ 6:31 pm
I looked at the log which is very busy

Thank you for the follow up @Geoff_Bulte, very appreciated!

Now that I have the requested time frames (thank you again) I have enabled the mentioned diagnostics on your account. What this action will do is the next time that Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our servers. I will keep an eye out for the upload and will touch base again once it has come in so you know we have it.


Update: I just checked our servers again and it looks like the report has come in already. I will be attaching the mentioned diagnostics to your ticket for review by the tech team. Once they have completed their analysis I will be sure to share their thoughts/findings with you asap.

Hello @Geoff_Bulte,

In the “Device Setup” screen for the Cambridge CXN, can you try turning on the “Disable MQA USB HID Protocol” option and see if the behavior changes at all?


I don’t have exactly the words “Disable MQA USB HID Protocol” but there is a button to disable MQA USB in the advanced options in the Audio tab, which I did. Unfortunately no improvement. On the CXN the display flickers between “96Khz” and “No Signal” as Roon skips through the playlist.

If it adds any hints …

I feed my CXN via AirPlay , then by coax to my Audiolab M-DAC for my headphones this gives me 44.1 only .

I just added a RPi with Riopeee to run the M-DAC directly on USB , this gives me 96 (the limit on USB). I then thought that the CXN would give me 192 when running effectively as a DAC only so I tried the USB feed from the RPi.

I saw 96 indicated, so I reset the USB from 1 to 2 and then saw 192 Hurrah !!

BUT Roon , via RPi sees the M-DAC and allows adjustment as an audio devie etc but Roon does NOT see the CXN in the same way. It sees it as an AirPlay speaker but not as a DAC

Is this the same issue I wonder. I have reverted to RPi -> M-DAC and Airplay to the CXN but something is not quite right. I havent had time to dig deeper yet. My firmware on CXN is up to date as is CA Connect and Roon

Mysterious ? CA have no intention of becoming Roon Certified from their last comms


I dont see any Device Setup for the CXN as a USB DAC , just as an AirPlay speaker


Hello @Geoff_Bulte,

I would recommend you reach out to Cambridge Audio support and tell them you are having issues with the CXN using USB on Linux. The errors that are shown in your log indicate that the device is having issues communicating with the Linux audio stack, which is something that is not specific to Roon. This issue is happening before Roon can even see or identify the device, so unfortunately there isn’t much we can do here.

If you get some guidance from Cambridge about what may be causing this issues or further troubleshooting steps, I’d be happy to assist. If they provide you information that fixes your issue, please share it here so that other users can find this information!


1 Like


There is a second thread talking about this

It looks like the CXN will work when set to Class 1 USB ie up to 92 khz, but doesn’t work when set at Class 2 , up to 192 khz

Linux is not recognising the CXN hence Roon doesn’t either


I contacted Cambridge Audio and they agreed to roll back their firmware update for me. Unfortunately the problem persists so it appears it’s not CAs fault. Any ideas?

Did CA indicate a specific roll back for you or in general. A roll back will rob you of Tidal in CXN if I am not mistaken ? That was the main change in the recent firmware upgrade.

It would be better if they fixed the Linux issue without roll back


Have you been following this pone as well

same story . I did some testing with a Windows 10 ed point and the Linux one of the RPi


They rolled back to the previous version but the problem persists suggesting/confirming it wasn’t a CA problem. They did undertake to investigate becoming Roon ready

I know they have no interest in Roon Ready , they don’t think its big enough to warrant the effort.

Its funny that your NUC is not seeing the CXN, I used a Wireless Laptop (Sony Vaio) , then USB cable to the CXN , it showed the CXN as a connected DAC both on Class 1 & 2 selected on the CXN

I played 24/192 tracks via this set up with no problems.

Just a dumb thoughts , did you disconnect the CXN from the network completely ? I set it to “wired Only” then pulled the LAN plug , that way the CXN was simply a DAC standalone. Otherwise you may get IP conflicts

You can see the signal paths etc on the other post


Hello @Geoff_Bulte,

  1. Is your Cambridge Audio CXN the V1 or V2 revision?
  2. After discussing with the tech team, they enabled a possible workaround on your account, which should change some low level details related to how Roon communicates with the DAC. Please reboot your Roon Core to allow this change to register. You should now see the “Disable MQA USB HID Protocol” toggle that was mentioned before in Device Setup for the device. Let me know if enabling this setting changes the behavior you are seeing using both the USB 1.0 and USB 2.0 options on the CXN device.