Can I "bulk remove" something that's been typed into Roon's album editing fields?

Content you’re reporting an issue with

Bulk Editing of meta data

Have you made any edits to this content in Roon?


Is the album identified in Roon?


Is this content from local files, TIDAL, or Qobuz?


Screenshot of import settings

Description of the issue

Back in the dark ages, before I discovered that meta-tags in my files were a better option than tagging from within Roon, in case my database becomes irreparably damaged, I went through & bulk edited many, many albums into their main groups.

So, I have quite a few albums that look like the one below:

Here, I’ve selected, like, a thousand albums & put “Library” into the album artist field so that they all sort together when viewed by artist.

Now, I would not only like to sort them by using meta-tags but also by “LIBRARY: Label”.

Unfortunately, I can’t seem to remove the previous manual tag when more than one item is selected.

I can select two albums, delete the word “Library” from the album artist field & the “save” button becomes active as though something has been changed. Unfortunately, when I click “save”, the field remains unaffected.

If I go into Metadata Preferences & choose “prefer file” (which is the exact thing I click on when doing them individually) it also allows me to save my choice but does nothing.

Is there a way of doing this that is eluding my tiny brain?

Is this a bug that should be fixed?

Do we not think that, if the save box becomes active, it should save my changes?

Does it not seem reasonable to be able to remove something from one of these boxes & to have Roon revert to its normal behaviour of looking for something in the meta-tags?

“What say ye good people?” (And for a bonus point, what is the reply to this well known music quote?)

Try selecting in batches of less than 1000. I found I could select 998 and get the Edit Album tab, going to 1000 and over, that tab would not appear.


I’m only trying it with two at the moment, just to invoke the bulk edit window.

Try as I might, I cannot clear that entry unless I do it individually.

There should be three tabs in the edit menu. The second one is metadata preferences. You should be able to select Roon for album artist, I think. (Can check when I get home)

1 Like

Thanks & yes, indeed there is.

Sadly, as mentioned above, I tried that with no luck.

Yeah I tried that as well now. First I added the same Album Artist to two albums. Then I selected them both, went to Edit and …

And after saving it does … nothing. The edited album artist stays on each album. Seems like a bug to me.

Going through the album edit for the 2 multi-selected albums, the Album Artist was displayed as the same, as expected. After deleting it …

… and saving (the Save button was active), this also has no effect. The edited album artist stays on both albums.

The only way to get rid of it is editing both albums separately. (I am on B1191 for both ROCK and the macOS remote, because I am using earlyaccess)

1 Like

After selecting your albums, then edit, try selecting revert edits, then album artist, then revert

That reverts all edits though, not just selected ones

Hmm, I didn’t think so when I tried it as I specifically selected the album artist as the data to revert.
Let me try again…

Well I have to admit I just thought so because it doesn’t indicate anything else. I’ll try as well :slight_smile:

Works for me, I edited two fields in two albums, and reverted just one field successfully

It does. It says “Revert edits” in plural, so I never clicked it because it scared me, thinking that it reverts all edits on the album. In fact it brings up a menu to choose what to revert. Cool, and this should solve the OP’s problem.

However, it’s still a bug that the other options don’t work for multiselected items. (If they don’t on purpose, they should not be enabled in the first place)

That’s an excellent workaround. Thanks! :slight_smile:

1 Like

So I was just able to revert 1500 albums in one hit.

Which was a lot less painful than the 300 I did last night one at a time! (Because I didn’t get any messages to tell me there had been further replies following @Suedkiez confirming my initial problem.)

Thanks again. All sorted now. :slight_smile:

You can bulk select a group of Albums and set the Metadata Preference to "Prefer file


I would guess the best bet is to Externally bulk edit the Album Tag in the Files , the do a “prefer files”

I have 2 tools that will Find and Replace , JRiver and MusiCHI tagger both unfortunately licensed , but I suspect MP3Tag may help here and its free

PS MP3Tag or TagScanner doesn’t seem to either , you could always get a 30 day JRiver trial , that certainly will , it would be my first choice

Oh, don’t worry, I do! Everything in my Roon is set to prefer file. (See my screenshot at the top of the thread.) Unfortunately, as we know from bitter experience, the word “prefer” is a huge grey area that Roon routinely ignores in its effort to provide “richness”. (For example, it doesn’t matter how I name my tracks in the file, Roon will display the tracks whatever way it wants to. This is particularly true of classical music, especially when the albums are “identified”. It took me a while, but I really like Roon & the user interaction we get here, so I’ve made my peace with it & just do what I can to get things displayed how I want them.

For tagging, I use Yate & it’s far & away the most powerful tool I’ve ever used for tagging, especially as the owner is able to write bespoke codes that I can add in to do specific tasks. (For example, I like to keep the A & B side numbers preserved in my track names for album rips & yesterday he wrote me a code that will allow me to select a group of tracks & click a button. It will then add A01… A02… etc. to the selected tracks. Saves hours!

Thanks everyone!

Just for reference, you can replace (or remove, which is replace by nothing) using Mp3tag’s Actions feature, which has action types for Replace and Replace with Regular Expression.

Are you saying that MP3 tag can remove things you’ve added inside of Roon?

No outside of Roon , but Roon will see a change in the file and re-import , then you have the updated version in Roon


Nope. That doesn’t work. I’ve been updating them outside of Roon & yes, Roon sees the change & spins away for ages, but stubbornly refuses to relinquish its grip on the info I added inside Roon.