Can I listen to ROON just through Laptop's & Mobile's built-in speaker/headphone?

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

There is only one audio device shown connected to Core and it call “HDA Intel PCH, ALSA”. I dont know what is it.

Number of Tracks in Library

Description of Issue

I try to listen Roon through the Laptop’s & Mobile’s built-in speaker/headphone without success. Do I have to have a Roon ready audio device connected in order to listen to Roon??

I believe that audio device shown is your laptop sound card/ device.
Just press enable and I think you will have audio.

Sorry no. No music even if I enable it…

That’s odd as it says that is directly connected to the core.
What does the device settings look like for that audio device?

i think this is the soundware for the NAS which has a very small bimper speaker.

Where is this screen shot from? what device? do you have Roon running on your laptop? or your mobile device?

The screen shot tells me that Roon is not running on any devices (that Roon core can see). Make sure the devices are on the same subnet on your network.

The devices that are running Roon remote should show up as endpoints and you should be able to play to the devices default speakers (phone or tablet or laptop). Roon must be running on the device and the zone must be enabled in Roon (settings/audio). On a PC make sure to select the right output that matches how your speakers are connected. You can even play to bluetooth speakers if they are paired with your devices.

Just show us " Settings" “About” please

1 Like

or like Jim_F shows, settings/audio

Well, he did show “Audio”…

1 Like

That’s what I thought which as only one device shown I assumed that was the laptop sound card/ device

But apparently not it appears to be a speaker in the Nas.

1 Like

Yep, that’s why i requested he’d show us “About”…


Sorry for late reply. Here are the about & audio page shot.

I have been trying to sort it out without success. Appreciate for your inputs!!

It looks like your core is setup up on your NAS. That would explain why your first post is trying to use ALSA for the output (Linux box).
You don’t have any audio listed for Settings>Audio>“This PC”?
Did you reboot your remote device?

1 Like

I dont want to use ALSA for the output and it is found by default. Strange that nothing listed for audio for “This PC”. Yes I reboot both NAS and PC. I will reboot it again later and see…

Thanks so much again!!

Have you checked your Windows machine firewall to allow an exception for raatserver.exe?
You should have two, one for Roon and one for raatserver.exe.

Hey @Charles_Chan

Sorry to hear about your troubles here and for the delay getting back to you. We’re happy to see that you received some pointers from your fellow Community members.

First we’ll want to ensure that all of your devices are on the same subnet. Then please try turning off your firewall on your PC, restart the machine, then launch Roon to see if your PC audio outs appear.

If so you can add exceptions for Roon using this guide from our Help Center

We hope this helps get you going. If it doesn’t please let us know and we’ll troubleshoot further. Thanks!

Hi Jamie,

Still no luck… In fact, the Roon core has been changed to install in qnap Nas in the same wireless network. I don’t know and don’t know if there’s any firewall in the Nas.

I have been trying to listen to Roon through Android and laptop without success. I’m sending you screenshots of mobile

Awaiting for your help on this.

Thanks so much Charles

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Hey @Charles_Chan,

Thanks for keeping in touch on this community thread and over email.

When we kindly asked to fully disable your firewall or antivirus, it wasn’t necessarily on your NAS, but on your PC. Could you please turn off any firewall / antivirus on your PC, restart it and then see if you can enable it in Settings → Audio?

Thanks :slight_smile: