Can iPeng make the iPad a Roon endpoint? [Yes. Implemented in iPeng 9.3]


#142

AWESOME… best feature to come available for Roon in quite awhile. :slight_smile:

Great job @Joerg_Schwieder!


(Joerg Schwieder) #143

@wizardofoz

I’m not sure, but some iOS versions did have issues with certificates, it can also sometimes take a while until it shows up.
The easiest way to share the feature among multiple devices is usually to enable iCloud on all of them, iPeng will then sync the feature all by itself without having to use the App Store.


#144

I also noticed this gives some basic controls on the lock screen on my iPad and iPhone that was lacking with the Roon app.

Sweet!!


(Joerg Schwieder) #145

Yes, unfortunately the lock screen widget and the Watch App don’t work, though, because Roon doeesn’t support the JSON/RPC command interface these use (because standing connections take too long to establish).
For the Watch we might be able to find a workaround, though, but I can’t promise anything.

But the lock screen control while paying works, that has the main App running and able to send commands.


#146

Thanks, I found this really helpful - with the same problem on skipping tracks, the Bitrate Limiting trick worked for me too!

Thanks also to @Joerg_Schwieder, I’m a long-time user of iPeng and really appreciated all he did there with making LMS what it was, as well as his responsiveness to my (tiny) feedback and delighted that not only has he taken this piece of work on but also made it available to iPeng users without any additional charge. Hattip!


(Kevin) #147

I also needed to change the settings for bit rate limiting. Otherwise, works like a charm on my 10.5" iPad Pro, sitting on my front porch, out of my kids hair, sipping a beverage. Thanks, cheers!


(Joerg Schwieder) #148

That’s good to know, you are setting the small buffer, right?
It might be that Roon has problems to cope with iPeng’s normal buffer size which is larger than what normal Squeezeboxes use (although SqueezeLite can use similar buffer sizes).
I’ll experiment a bit with this and maybe make it the default setting when used with Roon or something like that.
The buffer settings is primarily intended for mobile use where it helps in case of varying network data rates.

Is this for standalone playback or when syncing with other devices?


(58LesPaul) #149

Standalone playback for me.


(Kevin) #150

Yes, changing to the small buffer. The first time I started playback, it played one song and then stopped. Made the setting change and playback resumed pretty immediately, and haven’t had any issues since. I should try to switch back and see if the problem returns. I am using it for standalone playback on a new 10.5" iPad Pro. Thanks for your work!


(mannp) #151

@Joerg_Schwieder thanks very much for allowing my ipeng playback to now work with roon.

Now my old iPad can get some use to justify itself :slight_smile:


(Steve) #153

In the garden listening to Roon via my iPad and a Bluetooth speaker - great stuff!

One question, when I adjust the Roon volume slider it also adjusts the iPad volume (which I usually leave muted). Is this normal/expected? I’m guessing it’s because it’s properly integrated into iOS?


(Joerg Schwieder) #154

I’m not sure I understand the volume question.
If you are using the iPad as a player through iPeng then changing the volume of that player obviously also changes the iPad’s volume … I mean … that’s what you are playing on, isn’t it? And of course you can control it remotely :slight_smile:
Or do I misunderstand which volume change you mean?

iPeng should turn the volume back to what it was before you started it when the player shuts down but that might be several minutes after playback stops to allow you to restart playback remotely.


(Anders Vinberg) #155

See my note above:


(Steve) #156

No, I think I’m just having a dumb moment. Am so used to just using idevices to control other devices I got a bit confused! :relaxed:


(Joerg Schwieder) #157

Yea, and it’s actually something Apple doesn’t have in mind as a use case which is why this is pretty complicated, unless you want a dual volume control, which is a usability mess (controlling an internal “App” volume relative to the system volume which are then both effectively being multiplied).
It’s also deprecated, I still hope they don’t remove it anytime soon or at least develop an alternative (luckily, it still works in iOS 11).


(Brad Tombaugh) #158

OK, I’ve also gotten iPeng to work as a Roon endpoint on my 9.7" iPad Pro w/iOS 10.3.2, but I’m not exactly sure how… :wink:

When I purchased/installed iPeng 9, it didn’t prompt me to purchase Player. I eventually found the in-app purchase, but I’m not sure where. Once I had added that, I got the link for the Roon App on the main screen – once…

I was able to define iPadPro (iPeng) as an audio zone, but when I tried playing, it would apparently stream the music very quickly, but not produce any sound. i.e. the song showed as playing for a few seconds, then looked like it had ended.

I rebooted the iPad, and reopened iPeng. It doesn’t show the link for the Roon app, but it is working as an endpoint.

I’m not certain how to turn iPeng on/off though, so I’m afraid that it’s running in the background and using up the battery even when I’m not playing music?

I’m very happy to have the option, though, and hope that the bugs will be straightened out in future updates.


(Rene Bouwmeester) #159

After 5 minutes of inactivity, iPeng will go to sleep in the background like a regular iOS app – no need to worry about it eating up your battery life. You’ll need to re activate the app to make it reappear as a Roon zone.


(Brad Tombaugh) #160

Thanks for the reply!

I tried looking on the developer’s website (PenguinLovesMusic.com) but didn’t find any documentation on this… I suspect that’s because it’s new functionality.


(Joerg Schwieder) #161

There’s a post on the blog:
http://penguinlovesmusic.de/2017/07/13/summer-news-from-ipeng/
Could you send me a screen sho of the main menu? I’m surprised the Roon menu doesn’t always show. And maybe also a screen shot of the player menu, the one you get if you tap the player name in the bottom left.

The App will indeed not permanently run in the background.
Usually it’s about five minutes after the music stops (this is managed by iOS, but 5 minutes is the usual default).
If you enable “Settings->iPeng Settings->Preserve Connection” the App will keep running in the background permanently, but only as long as your iPad is connected to an external power source, otherwise it’s still 5 minutes.

iPeng will only prompt you for the Playback purchase the second time you run it :slight_smile: The first time it comes up with a lot of other explainers and we didn’t want to clutter that too much …
The purchase menu is “Settings->Enable Playback” and will no longer show once the feature is enabled (why should it …).
But you are right, it might make sense to have that menu more prominently when you only use iPeng with Roon.
Usually iPeng is meant to be a Squeezebox remote in the first place so most people will be busy trying it out in that role first …


(Steve) #162

It probably doesn’t make sense to modify everything just for Roon users, but I have to say I only use ipeng fir the purpose of playing music from Roon. I’d love a ‘Roon mode’ where only the relevant bits are visible. But I get that this isn’t the apps primary purpose. Just thinking aloud…(as usual)