Can microRendu handle multichannel?

(Jesus Rodriguez) #7

I would not mind having a look at that setup via remote connection. Send me an email:

(Horacio Lewinski) #8

Hello Jesus. Bummer I didn’t see your message earlier: I started a new installation on my PC. Still trying with WS2012R2, but attempting the HQPLAYER route for convolution. Once that works I’ll add Roon, and then Tidal. And if it doesn’t work I’ll reinstall back again with JRiver. Bottom line is I don’t have a machine to show now.

I will likely come back for help :blush:

I’ll be more than happy to share my setup with you.


(Michael Kneznekoff) #9

I have the ExaSound e38 8-channel DAC. I know that it works with Apple and Microsoft computers via USB and presents itself as an 8-channel audio device. Will microRendu support that?

1 Like
(Jesus Rodriguez) #10

No. ExaSound has not released the Linux drivers for their DACs.

(Jesus Rodriguez) #11

Sonicorbiter - Multichannel
I have been conducting some tests in order to get my hands around multichannel playback. Here are the results so far:

The following is based on tests conducted with a miniDSP UDAC-8 - asynchronous USB to 8 channel analog RCA converter. The DAC is capable of 8 channel @ 24/192kHz so no DSD tests have been conducted. I’m powering the DAC with my UpTone Audio LPS-1 power supply set to 5V and it sounds great considering the overall cost:


  1. Roon / RoonReady output mode - confirmed
  2. JRiver / MPD-DLNA output mode - confirmed
  3. MPD direct with MPD controller - confirmed
  4. Logitech Meda Server / SqueezeLite - busted, does not play
  5. HQ Player / NAA - confirmed

miniDSP UDAC-8 - confirmed
RME Fireface UCX - would be interesting to test
ExaSound multichannel DACs - busted, exaSound needs to provide Linux driver

MPD is converting stereo into whatever number of channels your DAC supports. MPD does this by copying the stereo channels into the remains channels. Multichannel files appear to play fine with multichannel test file.

SONORE computer audio - Rendu | microRendu | Sonicorbiter SE

(Mark Specht) #12

I just tried to play Multichannel sound (1+2 mains; 3+4 subs) with 1) a Microrendu and Roon 2) a SonicOrbiter based System (Vortexbox UK, Audiostore Prestige 2) and 2 devices: a) MiniDSP UDIO-8 and b) RME ADI 2 Pro. Roon is set to 7.1. mode; I am getting for both devices the message “Failed to Initialize Audio Device” once I hit play. It’s all properly recognized with Roon, but won’t play.
If I use a Mac instead as the bridge or Core device - no problem.
Any idea?

(Jesus Rodriguez) #13

What does Apps / DAC Diagnostics show?

(Mark Specht) #15

Here‘s the Vortexbox Nova + RME ADI-2 Pro FS, will post Microrendu settings later:

(Mark Specht) #16

And here the same setup with the Microrendu:

(Jesus Rodriguez) #17

I had some discussions with Roon offline about this issue and Brian suggested we try a change in the RoonReady code. We are going to do this, but it will take some time to implement and test. If the fix works and does not seem to break anything else we will release it soon.

1 Like
(Mark Specht) #18

Great thanks! I assume it means that in this case both the Microrendu and Sonicorbiter based servers would work in a 7.1 setup, hence my Vortexbox Nova machine as well?

(Jesus Rodriguez) #19

I’m not involved in the Vortexbox Nova project so I can’t say one way or another.

(Robert Bienstock) #20

Will any of the endpoints running the Sonore os (I have a SonicOrbiter, a microRendu and an ultraRendu) pass multichannel audio to the miniDSP U-DAC8? This Thread implies yes, but I need to check.

(Jesus Rodriguez) #21

It should work, but it does not work at the moment and we are looking into it. I’ll post the solution were when we have it resolved.

(Jesus Rodriguez) #22


Roon had us try some things and unfortunately we could not fix the issue on our end. I have provided all the feedback on the issue back to Roon and they are going to take it from here. When they have an update for RoonReady we will implement it and retest.

(Jesus Rodriguez) #23


Roon updated RoonReady, we updated RoonRendu on the Rendu and multi-channel is working again. Please update your units, wait for the Back to Main Menu link, and reboot your unit.
Don’t forget to go to Device Setup / Show Advanced an set Channel Layout on Roon.

1 Like
(Mark Specht) #24

Great That worked. Thanks Jesus!

(Mark Specht) #25

One thing that does not work in this set up though is Upsampling in Roon. Here I get pops and clicks. I wonder if this is a general issue or due to my setup:

Multichannel sound (2 mains; 2 subs) via Microrendu and Roon (core on a Mac Mini 2012 High Sierra) hooked up to a RME ADI 2 Pro (Channels 1/2 for Subs, Channels 7/8 via SPDIF to a Benchmark DAC3B for the mains). Roon is set to 7.1., Upsampling to max PCM rate generates the afore mentioned clicks. Everthing’s fine when not upsampling.

(Jesus Rodriguez) #26

You need a lot of power under the hood to do that.

(Mark Specht) #27

Intersting. You think that Mac’s to slow? I’ll try another machine to check.