Can no longer mount my Synology Media volume

Out of the blue, my Roon (server running on a Synology) will no longer mount my media drive (which is on the same synology)

Other machines on my network (iPads, Macs, Windows and my Linux server) can still mount with no problem but the Roon app on my iPad just tells me there was an Unexpected error:

Any ideas?

Are the other devices connecting to the machines host name by any chance? Has the IP address of the NAS changed?

I’ve tried both – I’m actually using static IP addresses

I use truenas, on my own Frankenstein build. My core runs in a virtual machine on it. Does the core run natively on the synology?

Yes it’s running natively — this has been working fine for the last year — very strange

I’m assuming all of yesterday’s Roon updates were applied 1.8 (943) ?

Yep - my worry is that that is what has caused the problem!

Can you ssh into the synology box and restart the core?

I had already tried that and in fact I tried rebooting the entire Synology drive. It would be nice if the error message said more than “Unexpected error” though.

There seems to be no way to edit the existing entry to edit/change username/passwords either, which is odd.

In the end, I just changed the permissions of that Media share (recursively) to 777 so no authentication is needed any more.

If your NAS runs DSM 7 then connecting to network shares in Roon does no longer work. Why you even try to network mount a local folder - IDK but sounds silly to me (unless it’s the last possible option like for some QNAP users that are currently affected by a bug that prevents to use better options reliably or at all).

@BlackJack I’m not sure I quite understand what you mean? Mind elaborating?

So the music library is a local folder to the Roon Server as both are located on the same NAS (PC/server/machine how ever you want to call it).

Ok, understand now. Other external devices, ie a desktop still have to mount.

There are no other relevant devices as far as I read and understand the OP.

I guess you must have a different version of DSM 7 than do I.

After I adjusted permissions on the share so as to no longer need authentication, Roon had no trouble mounting the share and making the local library available.

Normally I have that share disabled as Qobuz had (I always assumed) all the content so I was surprised to discover that most Tangerine Dream was missing.

I would like to not have to subscribe to multiple streaming sources for the sake of a few albums that are missing.

I don’t have DSM at all. I was referring to other posts from users and even the maintainer of the RoonServer package who tell that software in packages in DSM 7 are no longer allowed to mount shares - but maybe you don’t use the package at all? Maybe that is also why you have to use the share to access a local folder? Maybe using works differently than using the external IP-Address have you tried?


My apologies to you. It seems you are quite correct about not being able to mount SMB shares any more.

I just realized that the “Add Folder” option was not an SMB share (I thought it was) and the only reason it had stopped working was because of file permissions (which I had fixed as part of removing user authentication) and so I thought I was in fact mounting a share.

Thank you for your patience.

A user gets created for each individual software package installed under DSM 7. Adding the individual user for the RoonServer package to your library folder and giving him sufficient rights might do and is possibly better than removing rights (or give rights to everyone). Read more about it in this post:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.