Can not find my new NAS library


I just changed my QNAP NAS ( T212 turbo) to a new QNAP NAS (T131).
I can no longer show Roon the path to my new NAS.
It only shows me folders on my Mac, Desktop, applications but no Browse to network button.

Can you help please?


Hi @Bernard_Aubin ----- Thank you for the report and sorry to hear of the troubles.

Moving forward, to help aide in our evaluation of this behavior you are reporting may I kindly ask you to please expand on the description of your setup using this link as a guide and furthermore, please provide a screenshot of your “choose music storage folder” window which can be accessed by going to the “storage” and selecting “add folder”. This is where you should be able to add a network share from.



Hi Eric,

Here you go:

Hi @Bernard_Aubin ---- Thank you for touching base with me and providing the requested screenshot, appreciated!

I want to make sure that we are on the same page here in terms of what the “issue” is that is being experienced. I see from your screenshots that you are being given the option to add a network share in Roon, are you unable to add the NAS using the instructions found here?

Furthermore, it sounds like the QNAP is housing your musical collection and not hosting your Roon core. If this is indeed the case you are going to want to follow the instruction here on how you can change your storage location while ensuring that your edits, playlists, etc are maintained by Roon. Having a a description of your setup as asked above would be greatly appreciated!


Hi Eric,

I am storing my music in my nAS. What are the advantages of running Roon Core in the NAS? I am not very good with less than basic software issues.

I can’t seem to locate my NAS is the Storage section of Roon.

My system:
-Mac Mini
Ayre Dac
Ayre Preamp
PAss Labs amp
Magico speakers
Rel sub.

I see your instructions but I can’t find the same headings on my system.

Regretting changing my NAS!


Hi @Bernard_Aubin ---- Thank you for the follow up, appreciated!

Our knowledge base has good information on why someone may choose to host their Roon core on NAS which can be found here. Furthermore, can you confirm that the new NAS is able to be accessed via the OS level on the MacMini hosting your Roon core?

If you can access the NAS via the OS, I would recommend using these instructions to mount the NAS via the “Add Network Share” window that you posted above.



I"ve tried all of the steps but keep on getting invalid path messages:

I see the NAS in Finder but can’t show the path in Roon Storage setting.

Thank you for getting in touch @Bernard_Aubin, appreciated!

Being as you core is hosted on a MacMini you will want to enter the “path” as the following:


If one fails please try the other and share your results, thanks!



The smb://nas-aubin/multimedia/music path worked instantly.
It has added my NAS music but, my Tidal albums are no longer included in my musix library as before.
Is there something I missed? All I see are my NAS albums.
thanks so much for helping.

Very pleased to hear the proposed yielded a positive result @Bernard_Aubin, thank you for the update.

It sounds like you may not be logged into TIDAL via Roon. You can check this by going to:

Path: “settings” - > “services” - > “TIDAL” - > “edit”