Can only play files 48/24 or less

Core Machine (Operating system/System info/Roon build number)

Intel Nuc Kit NUC8i3BEH with 128GB SSD. Running ROCK; OS Version 1 Build 227; Software Version 1.7 Build 667.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

On ethernet is ROCK; Melco N1A Music Server; Magna Mano Ultra network player running Ropieee. All connected to a Cisco Catalyst 2960 switch via short lengths of CAT 7 cable. Switch connected to Linksys WRT32X router via 10 Meters of CAT 5E. Remote is Macbook operating via Wi-Fi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audio is via Magna Mano Ultra (Raspberry Pi based) network player feeding a Denafrips Terminator DAC with I2S via HDMI cable

Description Of Issue

Last night, when playing music, files would just stop playing after 30 to 60 seconds into a song. Last night I did not notice if the files were hi-rez or not. Today I tried unsuccessfully to switch to piCorePlayer. Then reinstalled Ropieee this afternoon. Now tonight I am finding I can play files that are up to 48/24 but at anything over that the only sound is silence punctuated by clicks or pops. The magna mano in I2S mode is supposed to handle (and did until last night) files up 192/24.

Anyone have similar issues and have solved it?

@support. I was hoping this is a fairly distinctive issue that points to a clear solution that other folks have come to in the past. But I guess not. Support, can you help? Thanks!

Ok I’ve now moved the router close to the audio equipment and eliminated the Cisco switch. Same symptoms – no change.

Your Ropiee install reports back (thanks to RAAT) to your Roon controller what capabilities the connected DAC has when using USB. But you seem to be be tinkering (perhaps a better section for this question?) with IIS/I2S which is a one way protocol.

Now connected router and modem with 10M of optical cable, with optical converter on each end and replaced CAT 6 patch cords connecting the optical converters with the router and modem with tested good cords. This eliminated or replaced all previous connections between router and modem.

Still same symptoms no change. Low rez plays, high rez only clicks.

Not sure I am tinkering, if tinkering means asking the system to do something it is not designed to do or has not done in the past. The player has I2S HDMI out, the DAC accepts I2S HDMI in. The I2S/HDMI is configured to the same protocol on both units. And hi-rez has played before in this system configuration. So I believe I am reporting this in the right forum. The system is failing to do something it is designed to do and has done in the past. And (at least to my ears) I2S SQ far surpasses USB in this system. So I would not be easily resigned to ‘just live with it’ and use a USB connection.

Not sure Ropieee supports i2s over hdmi does it? @spockfish will be able to help here perhaps.

Perhaps you can screen shot the ropieee main page settings with specific hat details and show what the ropieee version is too.

I think this is more likely a rooieee/hat setup issue and should probably move to the #audio-products:ropieee area

I would also send a feedback to Harry here in this thread for now…under the ropieee advanced tab.

It does not. RoPieee supports HAT’s and USB for audio out.

@spockfish Hello Harry. That is strange… According to Jos at Magna Audio (the designer and maker of the Magna Mano) Ropieee supports up to 192 on an I2S connection. The I2S connection is not a Raspberry Pi contribution in the Mano but is one of the parts of the Mano designed by Magna to work off the board level I2S that I imagine is resident already in the Pi. Jos instructed me to use (in the Ropieee set up under HAT selection pull-down) the HiFiBerry Digi + Pro choice. I will try reflashing the SD card for Ropieee and trying again. Perhaps firmware got corrupted somehow. Then will take your advice and move this my issue over to the Ropieee forum.

I can only imagine that the software/firmware download on the Magna website is not the normal Ropieee, but is different? It is here:

@wizardofoz Hi Wizard. Thanks for your interest. Here is a shot of the Roon page and a shot of the Information page.

You need to ask the Mano designer what HAT is present (or what you need to chose in Linux for output).
Your selection here decides what capabilities to report back to Roon.


Hi Mikael – I think that is what I mentioned above. The designer told me to choose HiFiBerry Digi+ Pro. Or do you mean something else?

I think I see where I may have screwed up. :upside_down_face: I am now thinking that the Mano software/firmware is not standard Ropieee. It must be some specific adaptation or build-on to Ropieee designed to mate with the Magna Mano player and to enable I2S. I think on my first download of “Ropieee” I took it from the Magna website. Thats why it worked the first go-round.

Then the second time I downloaded Ropieee (after my failed experiment with piCorePlayer) I bet I downloaded that from Harry’s site, and so am now trying to run the standard Ropieee asking it to do customized things it does not know how to do! I will test this by downloading again from the Magna Audio site and reflashing the SD card for the Mano.

I hope that’s not the case.

They have never contacted me about some custom RoPieee build.

1 Like

Apologies, you did mention that. Sorry bout the confusion-

Hello Harry –

I could very well be wrong. Just speculation on my part. I know NOTHING about software!


If the hardware supplier is referencing a ropieee download on his web site then perhaps he should also test it and join here as a community user so he can be involved in this troubleshooting, at least will a PM to Harry being possible.

1 Like

Hi Wizard. Yes good suggestion. The vendor is a very nice and helpful guy. I will suggest this to him.