Can only see one USBridge at a time [Solved, cloned DietPi]

I have a Roon core running on Ubuntu on an Intel NUC, and several Allo USBridge endpoints each running DietPi and connected to a Modi 2 DAC. If I only power up one USBridge at a time, each of them works correctly. But if I power up more than one, I can only see one of them, and even the one I see frequently won’t play (just skips to the next track repeatedly). Unplugging the second one allows the first to work reliably again.

When there are 2 USBridges powered up, I can ssh into both of them at the same time, so I know they have different IP addresses and MAC addresses. When I power them up one after at a time, each is detected by the Roon Core and “remembered” (e.g., the name I assigned it comes up correctly).

What should I do next to troubleshoot?


Hi Michael,

What names have you given to the USBridge Zones ? Can you upload a screenshot of Settings/Audio ?

I think there might be an Ah Ha moment coming… :stuck_out_tongue:

I’m not on site so I’m afraid I can’t send a screenshot until probably Tuesday. But they were e.g., “Living Room”, “Roof Deck”, etc. English phrases with spaces between the words.

If it helps, having named device 1, device 2 never even appeared on the list of networked devices until I powered down device 1. (So the problem had already manifested before I named the second device.)

I thought what you were describing might occur if Zones were named “USBridge 1”, “USBridge 2” etc. but that’s not the case. Let’s drop a flag for @eric who might be able to tell more from some logs.

Don’t know if this is a factor for you, but I had a similar situation with two RPi/DietPi running Roon Bridge. I got lazy and instead of setting up both endpoints individually, I set up one and copied the result to the second and only changed the machine name and the static IP. That resulted in problems similar to the ones you describe.

In any event, the problems you are having sound to me like a Roon Bridge problem. Maybe deleting and reinstalling the bridge on both endpoints will resolve them.

For what it’s worth.

1 Like

cloning the booted cards is not recommended. you should flash the image to each different card then put them in each of the Pi’s then boot them up and rename then etc

1 Like

Yes, I understand. A mistake that resulted in the same type of problems the OP is having. If you read my post, the copy was changed to a new machine name and new static IP. Once the Bridge was deleted and reinstalled on the machine containing the copied card, then everything was OK.

1 Like

If this is a cloned card, the unique id of the Roon Bridges is probably the same. In that case, on one of the bridges, stop RoonBridge (systemctl stop roonbridge), remove the id file (rm /var/roon/RoonBridge/Settings/unique_id) and restart RoonBridge (systemctl start roonbridge). This will generate a new unique_id file.

If these are separate installs, it may help to change the hostname of (at least) one of the bridges (it is probably ‘dietpi’ in both cases): dietpi-config, 6. Security Options, 2. Change Hostname.


I know from talking to another poster, that Allo will pre-install DietPi/Roon Bridge. I’m guessing that when Allo sends out a USBridge with DIetPi/Roon Bridge pre-installed, they simply clone an archived image, rather than setting everything up new for each shipped device.

If that’s true, then should be made aware of what happens when a customer buys more than one USBridge.

Thanks very much! I’m sure this is the problem: I naively kept using the pre-installed DietPi/Bridge without thinking about whether or not it would have a UID burned in. I will test your suggested fixes when I can, probably Tuesday or Wednesday, and report back.

Meanwhile two other things:

@andybob is it worth giving details about what names along the lines of “USBridge 1” etc. can’t be expected to work, in case someone who did that finds this thread?

Also as a minor feature request, I wonder if the Roon Core audio setup UI might be able to show a diagnostic if two bridges with the same UID connect from different IP addresses. Since the cheapest thing for any third party to do is burn the same bridge install onto every piece of hardware, this is probably going to keep coming up even if fixes it in USBridge. (Or just key the UID off the MAC address by default?)

Thanks again!

On the USBridge image the unique_id is in /mnt/dietpi_userdata.

systemctl stop roonbridge
rm /mnt/dietpi_userdata/roon/RoonBridge/Settings/unique_id
rm /mnt/dietpi_userdata/roon/RAATServer/Settings/unique_id
systemctl start roonbridge

and changing the hostname worked! Thanks again.


Names was just a guess to investigate. Turned out to be UID and pleased you’ve solved it.