Can see ROCK roonOS web gui but remote does not log in

Roon Core Machine

NUC11 4Gb M2 SSD 128gb
Version 1.0 (build 259) production

Networking Gear & Setup Details

Std lan - devices all ping and assigned ROCK static IP

Connected Audio Devices

DAC, WaveRadio, Dragonfly - all working after ROCK install

Number of Tracks in Library

~22000 tracks

Description of Issue

ROCK worked fine since April when I installed it. Had a power outage couple of days back and cannot log into Core from remotes anymore. I can see the ROCK web GUI and I have tried reinstall, restoring from old database. Stays on log in screen and does not log on. Moved to new core while I troubleshoot, and that works fine. Have a log file to attach.

UPDATE: I reinstalled RoonOS on the ROCK, now it goes past the first “Connect” and moves to an “Upgrade” screen:

image

But it fails after a minute or so

image

So, still no joy.

Hi typically this is related to a networking issue preventing Roon from connecting to the Roon update server.

As a troubleshooting measure I would recommend rebooting you router and any other associated network equipment follow by a reboot of ROCK.

1 Like

I’m just another Roon subscriber, but I’d suggest providing more details about your network and how you have things connected. With popular home networking equipment, it’s easy to end up creating multiple networks without being aware. This is especially true with wireless mesh setups.

Add make and model details for each piece of equipment from the point where Internet enters your house to your Roon server. Also describe the complete path from your control device to your Roon server, including Wi-Fi access points, switches, and routers. Sometimes, just manually working through this exercise will reveal the problem.

1 Like

Internet ingress from street fiber backbone to ONT in basement–>ethernet–>Fios router–>cisco 8-port managed switch–>ethernet to all endpoints, including upstairs and listening room.
The two remotes I am testing with are on same switch - windows PCs with dragonfly-s to monitor speakers. so a very simple LAN setup, no mesh

Assuming that your Roon Server is also connected to the managed switch, that sounds like a solid setup. No VLANS configured on the switch, I assume, but it might be good to verify and/or try using a different port for Roon Server to see if anything changes. I’d try swapping patch cables too.

If the other systems on your network have no problems reaching the Internet, it’s just a process of elimination to figure out what’s stopping Roon Server.

Hi @Rahul_Nair,
Thank you for your patience while we worked through the queue. Are you still experiencing this issue? I’d also note that Roon recommends using unmanaged switches instead of managed ones.

Unmanaged Switches
Unmanaged switches are preferred over Managed Switches, but something to keep in mind is that some Unmanaged Switches still contain IGMP Snooping/Proxying settings or Flow Control/Quality of Service (QoS) settings in unmanaged mode. One example of such a switch is a D-Link DGS-105. These settings can cause issues on Managed Switches, and may cause issues on “fancier” Unmanaged Switches as well.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.