Can’t configure Chord Qutest properly


I’m using a Innuos zen mini mk3 and I just bought a Chord Qutest, but can’t configure it properly. The output of the Qutest is connected to a Naim Unitiqute2. I can play music from the Innuos (via USB or BNC) to the Qutest to the Naim. The only thing is that The Qutest doesn’t show up in the signal path. I have searched for solutions on this forum but can’t find one.

The Qutest is connected to the core (innuos), as I look into the audio settings. But the Qutest doesn’t show in the signal path, no matter what. I can select the Qutest as a zone, but no sound is heard. The so called “exclusive mode” is somehow not available in settings.

Tips and suggestions are welcome.


Hi @Frans_van_der_Veen, can you share a screenshot of what you do see in the signal path?

Just to confirm, you have the Innuos connected to the UNitiqute via USB, and then you have the Qutest connected to the Unitiqute, correct? How is the Qutest connected to the Unitiqute?

If you connect the Qutest directly to the Innuos does it work?

The Innuos is connected via USB and BNC with Qutest (I can select USB or BNC input on Qutest). The Qutest is connected via RCA with the Naim Unitiqute. The Naim only acts as a preamp.

So the audiochain looks like this:

Innuos - USB and BNC cable - Qutest - RCA cable - Naim Unitiqute 2

The internet connection is hard wired.

I have attached screenshots of the app (on iPad).

Since the Innuous is a Core,

  1. The USB connection to the Qutest is showing up in Settings Audio as the Qutest.
  2. The BNC connection to the Qutest is showing up in Settings Audio as the Innuos.

Try, choosing Qutest in Roon and the USB input on the Qutest. And then the reverse, the Innuos audio device in Roon and BNC on the Qutest. Does music play in each situation?

Hi Daniel,

Thanks for the help. Looks like I mixed up the input selections on the Qutest and the zone selections on Roon as well. The problem seems to be solved, as shown on the screenshot. Maybe it’s better I’ll remove the BNC cable, so I can’t mix it up.

With kind regards,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.