Can’t connect to Roon

Core Machine (Operating system/System info/Roon build number)

Salkstream III (core and music files reside on Salkstream III) running Linux, latest Roon build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear N300 WNR2000v2 router, Netgear Prosafe GS105 ethernet switch (unmanaged), everything connected via ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Salkstream III is connected to: Anthem AVM20 v2 via optical spdif, Oppo 103 via HDMI. Roon remotes include iPad 7th gen, iPhone 6s, Windows 10 PC.

Description Of Issue

Tonight I was listening to multichannel music via Roon on my Salkstream III. Everything was working fine until I tried to play another multichannel SACD file that I’ve played many times before. On the first track it would play about 15 seconds then skip to the next track. This happened every time I tried to play the first track. I rebooted the Salkstream, but it still did the same thing on that track. Thinking the file was messed up, using my Windows 10 PC, I deleted the SACD file from the Salkstream, did a Library Cleanup in Roon, then transferred the file again to the Salkstream from the original rip I have saved on my PC. Oddly, the transfer stopped a few times before completing. After a few attempts, the file finally transferred successfully.

Now when I try to bring up Roon using my iPad, iPhone, or PC, it won’t connect to the Roon Core on the Salkstream. Roon sees the Salkstream, tries to connect, but then says connection failed. I tried rebooting the Salkstream a few times, and rebooted my router, but still cannot connect to the Roon Core.

Something odd I’ve noticed; the Salkstream is now taking MUCH longer to reboot than normal. Normally it would reboot within 2 minutes, but now it’s taking 5 minutes or more to reboot. Once it does reboot, I can access the files on it from my PC, and even play files stored on the Salkstream using another program on my PC, but still cannot connect to the Roon Core.

Here’s the connection fail message I get (IP address redacted).

It certainly looks like something up with the network on that machine.

It’s odd that I can access the Salkstream using it’s browser interface, and even access and play music files stored on the Salkstream using my PC and my Oppo 103 with no problems. It seems Roon is the only thing I cannot access.

If it’s a network issue, it’s only affecting Roon for some reason.

Btw, I tried bypassing the ethernet switch so the Salkstream was directly connected to the router, but still no go. :frowning:

I got an email from Salk. Tomorrow he is going to remotely update Linux and reinstall Roonserver.

@support does this sound like a good plan?

He said since I can access the Salkstream without issue (except Roon), he doesn’t think Linux is the issue, but might as well update it while he’s in there. He believes reinstalling Roonserver should fix Roon, but I will lose all my settings.

I have Roon setup to automatically backup the database each week. Can I use one of those backups to restore my settings/database? Any tips on restoring successfully? The Knowledge Base doesn’t give much detail other than click on “Restore a Backup” on the Roon sign in screen or click on “Clean/Restore” under Scheduled Backups.

Hi @Saturn94,

Thanks for reaching out!

Is this the actual router in use? N300 technology is pretty outdated at this point, I would look into 5G router options as this is a possible bottleneck here.

I agree that a reinstall of RoonServer will likely help here, and yes you can use one of your Backups to restore the Roon database, instructions on how Backups work can be found here:

Thanks for the response. :grinning:

Thank you for the link.

Yes, we’ve had that router a long time and never have issues with it. Since the Roon “endpoints” are in the Salkstream (HDMI, Optical SPDIF), local music files are not streamed through the router. I never have an issue music from Qobuz getting bogged down. Other than streamed music from Qobuz, only commands from the iPad and iPhone remotes go through the router to the Salkstream/Roon.

In this case, I really don’t think the router is preventing the remotes connecting to Roon on the Salkstream.

I’ve thought before about getting a new router, but it seems like anytime I introduce a new computer component, there are always issues to work through (I am not a “computer person” and HATE that about computer stuff!). So when something works, I stick with it. Perhaps after the current issue is fixed I’ll revisit this.

Hopefully, tomorrow I’ll have some good news to report. :crossed_fingers:

1 Like

Mr. Salk believes the internal hard drive is failing. Neither of us can access the internal drive now (I could yesterday, just couldn’t connect to Roon).

He’s going to send me a new drive with Linux and Roon installed, and will set it up remotely once I receive the drive and install it in the Salkstream.

While I’m not happy this happened (having withdrawals already, lol), Salk’s customer service is second to none so I know it will be taken care of. :grinning::+1:

Thank goodness I have backups of my music files and Roon database! :astonished::smiley:

1 Like

Hi @Saturn94,

Thank you for letting me know that Salk Support is helping you out here, a faulty drive is a plausible explanation for this issue.

Hope the repairs go well and if you need any further feedback from our end, please just let me know!

Thank you. A new drive is on it’s way. I’ll update this post once we see if that fixes the issues. :crossed_fingers:

1 Like

The new drive arrived today, but I still cannot connect to the Salkstream, much less Roon.

I looked at what the Salkstream displayed on my TV (HDMI) while booting up and noticed this message:

Can anyone tell me what this means? I’m guessing this is telling me it can’t connect to the ethernet network? For reference, I’m very much a computer novice. I tried an internet search about that message but got some links that were talking way over my head.

I made sure I was using a good ethernet cable connected directly to the modem, but same results.

I sent an email to Salk and waiting for a response. I suspect I’ll have to ship the whole unit back to Salk. :frowning:

You modem won’t probably give you a DHCP address but your ROUTER should.

but it could mean that your ethernet port is dead or not connected correctly to your router

Perhaps you can draw a basic map of the connection from your ISP to the modem the router the switch (if separate) and anything else in between there and the Salkstream.

should look something like this

Thank you for the reply.

My apologies, I used the wrong term. I should have said “router”, not “modem”.

Normally, the chain looks like this (everything connected by ethernet wire)

Internet > Cable Modem > Router > Ethernet Switch (unmanaged) > Salkstream

As a test, I bypassed the Ethernet Switch and used a known good ethernet cable, like this:

Internet > Cable Modem > Router > Salkstream

Logging into the Router to see what’s connected I don’t see the Salkstream at all.

Sounds like it’s not working. Back to the manufacturer for advice again.

Just got this from Salk:

“… The error message you got indicated it could not find the network port enp3s0. That is because on your streamplayer, that port goes by a different name. Every board is a bit different…”

He included directions on how to hook up a keyboard to the Salkstream and correct this.

Fingers crossed! :crossed_fingers:

Good support but a very custom solution.

Salk’s support has always been excellent.

Salk initially left it up to me whether or not to send the Salkstream back to him. I chose not to thinking we could get it up and running quicker. Had I sent the entire unit back, he would have taken care of this without me having to do any of this. I give Salk credit for allowing either option as I’m sure troubleshooting/fixing remotely must be more time consuming for him.


With the instructions Salk gave, I was able to re-establish connectivity to the Salkstream on my network. Yay! As I understand it, the next step is for Salk to remotely finish setup on the Salkstream then load Roon (Roonserver?) on it. Before setting up Roon, I am to reload my music files from my backup, then I’ll be ready to set up Roon.


Salkstream and fresh copy of Roon is back up and running.

Thank you to everyone for your help.

Now, can any offer advice on this?

1 Like

Hi @Saturn94,

Happy to hear you’re up and running again! I will mark this thread as solved and you can continue to investigate the backup issue in the other existing thread.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.