Can’t download v1.5 build 339

Hi folks. Windows Server 2016 no GUI install. Roonserver up and running, but only on v1.3 build 200. Asks me to install update. I press button to install. Download keeps stopping and it just keeps retrying but gets nowhere. I can’t reinstall backup from last night (when I was using Windows Server 2016 with GUI, no problem) until I get back to v1.5. Thoughts on what I can do?

Uninstall and reinstall Roon?

A direct download of the latest version rather than the installer which must be updated?

Thanks. JCR

Thanks for reaching out, @Jeffrey_Robbins,

Did you recently install RoonServer here? Were you previously on v1.5 on this PC?

Do you have any firewall active on the Core machine that may be preventing the download?

Have you tried power cycling your Core machine and networking hardware?


Formatted drive to switch from WS2016 GUI to WS2016 core. Was on 1.5 on WS2016 GUI.

No firewall on. Power cycled everything. I can access the server via VNC Connect remotely so we know it is connected to the internet.

Here’s what it looks like on a separate PC control. Stuck trying to download.

Hey @Jeffrey_Robbins,

Thanks for the additional details here! Can you try uninstalling Roon on the Core machine (just the application, not your database) and reinstalling and let me know if you’re still experiencing this behavior?


Dylan, in Windows Server 2016 core, there is no control panel to add and uninstall programs. I did go into c:\users\administrator\appdata\local and I deleted the Raatserver and RoonServer folders and all subdirectories. Then, I tried reinstalling.

It was kind of an abbreviated re-install, which makes me think that there are other dlls and items elsewhere that have to be removed manually to get to a truly clean re-install point (thank you, Windows). In any event, the uninstall I did do with a subsequent reinstall has the exact same outcome — the update screen is stuck on the download of v1.5 build 339.

Can you instruct me as to what other items need to get a clean reinstall? My Roon settings and database are safely backed up to my NAS, so I’m not worried about losing data.

As an alternative, I see there is someone to use regedit to identify the GUID for Roon and then run some crazy power shell command to remove. Really over my pay grade absent precise instructions there.

Thanks. JCR

Thanks for giving that a try, as well as the additional information here, @Jeffrey_Robbins

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Ok sounds good. I did try one more thing: I did an extraction of the installerx64 on another PC and noted that there is an uninstaller within. I copied that to my downloads directory on the music server and ran it to delete the application but not settings files. It found 13 .dat, .dll, .blf and LOG files that it couldn’t remove. Once skipping those, it reported that Roon was removed. I ran the installer again and am back to the same stuck spot. So, at the moment, Roon v1.3 is running, albeit with no library as my backup is 1.5.

I assume the team will see all this as you have diagnostics going. If I find the actual spot on the server where Roon installs the uninstaller file, I may give a go at another attempt for a clean uninstall for another try at a clean reinstall. JCR

An update. I found where Roon stores the uninstall.exe file — the numbered subfolder under the application subfolder — and, after terminating RoonServer, I ran uninstall from that folder location. Room responded that an uninstall occurred and I got no error messages. So this time, I believe it was a clean uninstall.

I then reinstalled and yes, I’m stuck again with the inability to complete the download of v1.5.

So, Roon team, I hope diagnostics will now find the culprit. Thanks much. JCR

Thanks for the update, @Jeffrey_Robbins!

I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.


Here is a link to the log files for RAAT and RoonServer.

Kindly confirm receipt.

Also, is the installer available for download updated to v1.5 build 339? I am wondering if I should do a fresh download of the installer if it goes directly to the newer version, just to take the download issue out of the equation here. Let me know. Thanks. JCR

Hey @Jeffrey_Robbins,

Just wanted to confirm that the logs have been received, downloaded, and passed along to the team. As soon as I receive their feedback I’ll be sure to update you hear ASAP.


Hey @Jeffrey_Robbins,

The team took a look at the logs that you shared and I wanted to give you an update on their findings.

The team found some errors that point to possible security setting issues on Windows Server, along with some general networking difficulties. They’ve recommended trying to uninstall and reinstall again. When correctly done there should be no need to update once installed. When you previously reinstalled were you using an older version of the installer? Try to grab a new copy of the installer and give it another go and let us know if you continue having difficulties here.


OK, success. Grabbing a new copy of the installer, plus a reboot of my switch – plus a lot of work to figure out how to make the network share stick – and I have Roon running now on Windows Server 2016 core, without the desktop experience.

But, I have one remaining problem.

Easy to describe. Bringing up Device Manager via cmd using devmgmt.msc, there is no Sounds, Video and Game Controllers tab. Running mmsys.cpl shows that there is no sound device.

Windows Admin Center reports that the audiosrv and audioendpointbuilder services are both running, automatically.

In the desktop environment, I can load the Intel HD Graphics 4600 drivers (4th generation) and it automatically loads the Intel HD Audio driver at the same time. Not the case in core mode. Only the graphics driver loads.

I have used phputil to load the Intel HD audio driver inf and Windows reports that it is successfully installed on a device on the system. Yet, I get no sound device in Sound Manager or Device Manager and running a driver query doesn’t show any audio driver installed, notwithstanding that I’ve done so.

The motherboard is a Gigabyte unit and I’ve updated the chipset drivers and also installed the Realtek HD audio drivers that Gigabyte has on its own website. It installed, but yet, the Realtek drivers don’t show up either in the query list and still no device in Sound Manager or Device Manager.

For normal audio listening, I disable the onboard sound device on the motherboard. This isn’t an issue for the desktop experience. Thinking that might be the issue in core mode, I have enabled the onboard audio device, but it doesn’t show up in Sound Manager or Device Manager.

The only endpoint this affects is HDMI audio plugged directly into the server. Of course, that powers my multichannel Marantz prepro in my main system, so I have no multichannel audio. Bummer.

Microsoft TechNet is no help. They just say “well, your hardware and software aren’t Windows Server 2016 certified, so it’s your problem.” I am stumped. HDMI audio works fine in the desktop environment and not in core. Makes no sense. Thoughts all? Thanks. JCR

Didn’t Microsoft drop the Media Services role from Windows Server 2016? It was certainly present for Windows Server 2012, but browsing around the web reveals a lot of unhappy people who are no longer able to install Media Services on WS 2016.

I think Microsoft is heading for the Cloud. Latest reports from them is that they make much more money much faster on Azure than on-prem installations. Maybe the next server from Microsoft is Azure only? Lack of Media Services will probably be minor compared to that… Let’s hope Mono development approaches .NET qualities so Linux can handle the largest libraries.

Keep in mind that HDMI audio with Intel drivers works in WS2016 with desktop experience, even without the Media Services role. Therefore, what’s going on here has to be some process that is running in desktop experience mode that isn’t in core mode.

Anyone else out there in Roon land using WS2016 in core mode and successfully direct attaching to their server a USB DAC and/or HDMI audio? That would at least tell me that it can be done! JCR

My audio-pc is on WS 2016 core, and my USB-DAC runs fine. This is with the help of Audiophile Optimizer 2.20.
I use WASAPI with my Pro-Ject DAC.

I don’t know if you are using any software besides Roon. But I know that Phil, the guy behind AO has used years to implement audio into core server.

IHello, @Johs_Gjela. Yes, I use AO 2.20 with the WASAPI injector. Audio Phil is aware of my problem and he referred me to highendPC-Doctor, a US based colleague with Windows Server experience, to attempt to resolve. So far, no success on this issue.

No audio driver or audio device is recognized by my server when in WS2016 core mode. I’ve even tried a Music Streamer II USB DAC because it requires no drivers. As hardware in Device Manager, it appeared as an “other device” and did not cause Sound’s, Video and Game Controllers” or “Audio Devices” to appear. And it wants a driver, but there is none that works for it. So, that’s a bust.

Yet, all USB and HDMI DACs work in desktop experience mode.

At the moment, I’ve done a workaround by purchasing another reconditioned i3 PC running W10 and put Roon Bridge on there and HDMI audio from there, over the network and not direct connected to the WS2016 core server, is now working. Not sure if this defeats the whole purpose of AO to have none of my audio devices connected directly to core, but only via network. I’m sure that the HDMI our of the AO oprtimized server is probably cleaner than out of this i3 PC, but at least, it is working.

Meanwhile, since you have a USB DAC running on WS2016 core, will you share: (i) the make and model of your motherboard, (ii) th processor it uses and (iii) what Display and Audio drivers you have installed (ie, Intel HD 4600 graphics, which works for me in desktop experience but not core). Trying to understand why yours works and mine doesn’t. Thanks. JCR

As a test, try uninstalling the Realtek drivers, they have caused many an issue in the past and I don’t put them anywhere near the systems I build.