Can’t get Roon running on non-core iMac

Installed Roon and Roon bridge on iMac (High Sierra, osx10.9). I use Antipodes DS as Roon core.
Can play Roon on Arcam AVR 850 in room 1
The same goes for a B&W Zeppelin in room 2
Roon shows the devices in ‘audio’

Not so in room 3
The iMac is wired connected to the network.
Config there: iMac> AQ Dragonfly Red> B&W Zeppelin

I’d like to play Roon etc. From this iMac in room 3 -still using the Antipodes as a core- but it won’t connect.
Followed the instructions to shut Firewall and such. But to no avail.

You should only need Roonbridge on the iMac or just the Roon remote software if just using it as an endpoint. Run the remote on the iMac and see if it can connect to your core and see your other endpoints. If not then it might be a network discovery issue blocked by firewall or just reset your network gear try by powering them all off the Turning them on in order from modem/router to switches. If still an issue check that the iMac is in the same ip range as the other kit.

This is technically true, but I have run the full Roon on an endpoint without a problem.

However, you don’t need both the Bridge and the full Roon on the endpoint.

Hello @Hjcw_Roefs,

Do you by any chance have the OSX firewall blocking Roon on that 3rd room iMac? I would check this in your OSX settings using this guide. I’m not sure I fully understand what you mean by “it won’t connect”, does this mean that you do not see your Antipodes Core on the “select your Core” screen? Does this mean that your Dragonfly is not showing up in the Audio Tab?

Further, how is this iMac connected to the network? Is it connected via WiFi or Ethernet? Are you making use of any switches/range extenders/powerline adapters? What is your router’s model/manufacturer? Please let me know this info so I can better assist here.


Thanks for your reply Noris.
To answer your questions:
firewall diabled
Wired ethernet
Compal modem/router ( from Ziggo provider)
Two Netgear switches between the router and the Mac
Antipodes visible and working in the audio tag
Dragonfly mot visible there

I tried some things meanwhile:
Re-installed Roon bridge
Checked firewall settings: firewall settings adjusted so that Roon is allowed to pass Firewall
Restart the Mac
Checked if the Dragonfly was visible in the Roon settings. At first it was, now it is no more, after restart iMac
When it was, tried to open the newly installed Roon bridge on the Mac: no result. The colour of the Roon bridge entry in Applications turns grey.

I have been having trouble with my Schiit WYRD USB interface on the MAC after a reboot. I wonder if you are seeing a similar problem. Try unplugging the Dragonfly waiting a few seconds then plugging it back in. I am running the MacOS Mojave.

I had the same problem with a DVD drive. I found the solution by Googling, but now I can’t find it, again.

As I recall the procedure was to unplug device, turn off Mac, and then either turn on Mac and plug in device or plug in device and then turn on Mac. Sorry, it was awhile ago.

Try my above suggestions as one of them worked for me. The key was to turn off/on the Mac after unplugging device…

Thanks for letting me know @Hjcw_Roefs,

Can you please provide a screenshot of your Audio Tab on the iMac? Is there no devices showing up at all (not even “System Output”) or is it just the Dragonfly? Are the Netgear switches managed or unmanaged? Can you please provide the model?


Thnx for the suggestion Bob,.
I tried it, but alas…

Hi Slim , tried this, but unfortunately …

Hello @Hjcw_Roefs,

Can you please post a screenshot of your Audio Tab? It should look something like this:

Please let me know if the Netgear switches are managed or unmanaged, it may be worth a try to see if connecting your Core & Remote directly to the router allows the Dragonfly to be discovered properly.


1 Like

Hi Noris,
Some answers:
The switches are unmanaged
1st switch behind modem/router: TP link sg108
2nd switch: Netgear GS 208
They never caused any problem
Imposdible to directly wire the Mac to the router: too long distance

And the upper part of the audio tag

and the audio tab on the Mac

Hello @Hjcw_Roefs,

Thanks for posting that info. I believe the next step here would be to take a look at the diagnostics from your Roon Bridge. Can I please ask you to manually send us the Logs from your iMac using this link as a guide?

Getting them to us with a shared Dropbox or Google Drive link is preferable but if you don’t have either service, just let me know and I can provide an alternate upload method. Please let me know if this is possible and we can take a look at the diagnostics.


hi Noris,
I see what you mean, but the Roon server is not on my Mac, so no logs to be found there.
Roon bridge is in te list of programmes in Finder on this Mac, but can’t be opened, let alone that the logs will be visible.
So, here I’m at a loss. So sorry

Hello @Hjcw_Roefs,

No worries, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I kindly ask for you reproduce this issue once more and to let me know the exact local time in your country (ex. 2:26PM) that the following actions occur at:

  • The exact time you reboot the Roon Bridge and the Dragonfly shows up
  • The exact time that it disappears from the list of Audio devices
  • Any other timestamps for strange behavior that may be useful

Please let me know this info and we can take a look to see what the diagnostics say.


No worries @Hjcw_Roefs,

I have gone ahead and enabled diagnostics mode for your account and can confirm that we have received the diagnostics from your Roon Bridge device. Upon reviewing the diagnostics, the signs for this issue is pointing to something networking related going on.

Can I please ask you to verify if the Dragonfly Red works as expected when connected to the primary Core and not the Roon Bridge? Also, what is the behavior if you connect the second iMac (Roon Bridge) to the primary TP-Link Switch? Would you be able to run that test to see if the Netgear GS 208 could be causing this issue?


hi Noris, thanks again fotr taking the time to solve this.
The Dragon Fly works with other inputs (Spotify, Youtube e.g.)
Don’t know what you mean by yhe second iMac. I only have one. It’s quite complicated to change switches. They are in hard to reach plzaces nd it would mean that I would have to interrupt other activities.
No other device seems to get into trouble because of either switches (got some 20 devices connected wired to 4 switches.
Route: Ziggo modem/router> TP link switch1> antipodes server/streamer …
> TPlink switch 2 > Netgear switch 1> iMac > Dragonfly > B&W Zeppelin
> Netgear switch 2 > printer etc.
> Netgear switch 3 > Macbook pro/printer etc.
For the sake of certainty I reset the modem/router to be sure that everything wa working as it used to. That’s the case now.
Except Roon Bridge, which I re-installed on the iMac, again just to be sure, and restarted the Mac.
The problems remain: the Dragonfly is not visible in the Audiotag in Roon settings. Neither can I open it on my Mac. Instead of turning red, when opening the Bridge tag, it turms grey, and nothing else happens.