Can’t install RoonServer (20210727-beta) on DSM7-41890

I have had RoonServer running on my Synology NAS WITH DSM6 for “Years” and updated today to DSM7 and RoonServer was no longer working.

So I downloaded the above mentioned beta Version of RoonServer, changed also the permission of the “RoonServer” Folder to “System Internal User” and “Read-Only”. Saved it and try to install, but get always the same error message:

Error

Failed to repair RoonServer, and that I should change my permissions for RoonServer that I have had done.

Juergen

Here are some screenshots, for better evaluation

Hi Juergen,
Did you uninstall your old Roon Server from DSM6? I did not really check the behaviour of performing the update from the DSM6 version to the DSM7 version of Roon Server, as this is scenario to test
( → I can’t install the old Roon Server DSM6 version on DSM7 anymore, which means I have to install DSM6, then install the old Roon Server, then upgrade to DSM7 and perform the update to check if it is working. If it is not working, I have to wipe the system again and start from scratch with DSM6…
Maybe I find a workflow that might simplify this testing, I am thinking of using a virtual DSM. But this was not a priority yet.)

This is why I advised to uninstall Roon Server before installing the DSM7 version and perform a clean install. During uninstall your old database will not be touched and will remain in the RoonServer shared folder. But as I’ve learned you probably need to give extra permissions to the RoonOnNAS directory after install. (see this post for instructions)
I am currently checking on options to integrate this step in the installation (and think I have found a solution for the next release).

The permissions should be automatically be set during installation. You will see a installation wizard asking for your RoonServer and Music shared folder. (This won’t appear when performing an update).

Yes, now it is working. I have uninstalled RoonServer under DSM7 and made a (sort of) clean install of RoonServer under DSM7 and “Bingo”. Everything is working and my Roon database is as it was before. Great. Thank you for your help.

1 Like

Great!
If you did not do it yet, I’d recommend to adjust the permissions as shown in the linked post above.

1 Like

Thanks. Have done it accordingly. Great support.

Juergen

PS: Enjoy your cup of coffee :wink:

2 Likes

Hi Christopher, I followed your latest suggestion and uninstalled the package but was hesitant until you confirmed it wouldn’t affect the Roon DB (thanks!). I did notice there was a package installed in two places in the Package Center. Once I uninstalled both, the manual install worked!
I then had to re-establish the Core and it had to rebuild the library. After 14K tracks in about 15 minutes, it works great!! I still need to try some of the other cores. I’ve got a few.

Thank you so much for standing by your design and dealing with the questions. A true professional indeed.

1 Like

By the way, the auto update to the library works for new tunes added flawlessly for me anyway. And I’m using an old Synology loaded with RAM, cache, and SSD for the DB. Still with the Atom CPU.