Can’t upload convolution zip with wav files

Roon Core Machine

NUC6i5 16gb Ubuntu 22.04

Networking Gear & Setup Details

TP Link Deco M9 Mesh (3 units)

Connected Audio Devices

Roon Ready streamer

Number of Tracks in Library


Description of Issue

When uploading a new zip with convolution wav files the DSP screen crashes and i get redirected to the home screen. When I check DSP there is no zip file.

Uploading from MacBook.

Core and remote are both 970.

Just a suggestion… Double check your config files, and wavs again to ensure they are correct and referencing correctly.

No trouble loading new convolutions here, perhaps restart your core, and pc for good measure.

Sure, already tried a lot of different approaches. Otherwise I wouldn’t create a support thread.

1 Like

Guys come on, i’ve been using Roon since 2016 and know my way around a lot of software from a programming level. Did many measurements and imported them for multiple zones in Roon in the past.

This is a bug.

1 Like

I need @support for this.

Hey @jmvdv,

Thanks for taking the time to write in! I’m sorry to hear you’re running into issues with DSD convolution.

If possible, can you go through your process again, and get timestamps of when the crash occurs? That will help us better track what might be going on when the crash occurs.

Also, could you please upload the files in question here so our team can take a deeper look?

I’ll be monitoring this thread for your reply :pray:

1 Like

Hi @benjamin

Uploaded the .zip with the .wav files.

za 25 jun 2022 07:12:16 CEST

Unix time:

This time the remote lost connection for a second and after that went back to the main screen.

It would have been helpful for your fellow users just trying to help if
A. You’d had said up front that you’d tried different approaches etc
B. Kept the dismissive attitude toned down

1 Like

Just trying to get support with this bug.

A. You could say I got belittled by fellow users for writing a support question when i tried everything i could think off.

B. And I would argue that you are moralizing.

1 Like

Hey @jmvdv,

Thanks for sharing the files. Our team was able to reproduce this issue, and have a ticket submitted for our dev team to dig into further.

I can’t comment on a timeline for a solution, but the minute I catch wind of any updates you will be the first to know! :+1:

1 Like

Thanks a lot @benjamin !

1 Like

Just want to add I’m seeing the same issue. Try to upload convolution filter ZIP, and drops me back to the home screen, and the convolution filter remains empty.


Got a new DAC and was reuploading a known good convolution zip that worked in the past for the new audio input, but that wont upload now.

In testing I was able to upload a small ( < 8MB ) files, but larger files ( > 16MB ) would not upload. I didn’t have anything in between to try.

As a former web developer this seems like the default 8MB POST soft limit imposed in some web and java frameworks. Makes me wonder if this is something similar introduced in a recent patch. But that’s just a guess, perhaps I shouldn’t try to armchair quarterback here…

Hopefully that helps narrow it down.

1 Like

Hey @jmvdv,

I wanted to follow up to let you know we’ve just released a new roon build 1021 that addresses this issue. After updating to the newest build you should be good to go!

Please let me know if things are running smoothly after updating :+1:



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.