Can’t use native DSD on a Quad Vena II?


Intel NUC, Windows 10 with ROON Core

Allo USB Bridge Sign as ROON endpoint with RoPieee.

All connected over Ethernet

The native 256 DSD capable DAC inside Quad Vena II

Description Of Issue

I cant’t pick native DSD inside ROON. Only DSD over PCM (DSD 128).

Is this a linux issue, drivers maybe? I would like to try native DSD 256. Is there maybe a workaround?

I’m new to this with DSD.


Hi @Henrik_123,

Typically you have to configure the DSD strategy in the Web Interface for the Roon Bridge device. Can you check to see what DSD strategies you have available?

Thanks for your answer.

I do not really know what you mean. I can’t find any audio settings inside the Ropieee web interface. And I can’t seem to find where I can change the settings for my Bridge from the ROON interface.

But I noticed that my USB DAC under “device setup” in ROON is called a “Unidentified Device”. Could the problem be that my DAC is missing some drivers?

Linux does not do native DSD, unless the Linux kernel on the specific devices is patched for the specific DAC. That is why it is defaulting to DoP with the USB Bridge. You should contact Allo and ask if they have patched the USB Bridge to work with the Quad Vena II.

Well, my suggestion is to first use what you have and decide if you like DSD 256. See if the manufacturer provides drivers for Windows. If so, then download the drivers, load them on the Windows core, attach the DAC to the Windows Core via USB and then give native DSD 256 a try.

1 Like

Not the device I’m using.but…
Upscaling everything to DSD512…Except MQA over Ethernet from ROON ROCK > ASUS AC87 Router > Allo Signature > Project DAC…Without any interuptions at all…Just playing as it should
Native DSD playback is also possible with that setup…up to DSD512

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.