Cannot access music library on QNAP NAS

Core Machine (Operating system/System info/Roon build number)
Roon ROCK / NUC7 / Roon Server v.1.7 (build 710)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
QNAP NAS - recently added, replacing Synology NAS; after that I hit the problem described below; the rest of the network config is irrelevant, as not changed.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Not relevant here.

Description Of Issue
The trouble is I cannot access NAS from within Roon ROCK | Settings | Storage | Add Network Share.

I tried:

  • \host-name\share format
  • smb://host-name/share format
  • \ip-addr\share format
  • smb://ip-addr/share format
  • I tried accessing a folder which requires no authorisation (guest accessible)
  • I switched of AFP and NFS on NAS; it is only accessible via SMB 3.0
  • some more combinations with/without Workgroup/password etc.

Whatever I do, I get “There was an unexpected error: UnexpectedError”.

Is there any log to get any specifics? Message is not helpful at all. No details, no reference to any log, nothing.

I tried accessing all these folders from the macOS and it worked.

Any help?

Hi Stanislaw,

Did your try \\hostname\sharename ? (so with double backslash)
That works for my QNAP NAS.

Kind regards,

Set “Lowest SMB version” to something smaller than “SMB 3” and it should work.

Hi Gerard,
thanks, but yes - I did. It is only this web page form disfunction to translate double backslash \ into one . I should have written four backslashes: \\.

But that’s promising it works. Is your Roon Server on ROCK / NUC like mine?
Which version of QNAP OS do you have (mine:
Would you share your settings of SMB from your NAS?


Hi BlackJack,

thanks a lot!
This is hit - allowing usage of SMB2 solved the problem.

It is a pity, that official Roon support doc claims otherwise. Link here, quote below:

Regardless of what kind of device you’re using, you’ll want to make sure that the following is true:

  1. The folder is allowed to be accessed via SMB
  2. Your username and password should not contain any special characters
  3. Use SMBv3 when possible. Failing that, SMBv2 should also be ok, but do not use smb2 with large MTU as it has known compatibility issues with Roon.

Now I might have some trouble anyway, with larger MTU, or should I disregard this part of the official doc as well.

Wonder, what is really true for SMB / MTUs.
Adding @Support, though I am not sure if this is enough to make it through to Roon Support.

Anyway, thanks a lot once again. This was hit!


Hi Gerard,
would you please check if your NAS allows SMB connections of version 1.0 or 2.0 (anything below 3.0) - just to check?


Hi Stanislaw, not sure where I can find that SMB info. I have an old TS-419P with firmware Build 20201006. Does that help?

Kind regards,

After a little digging in the forum I found:

Current user issues imply that nothing has changed in the behavior of Roon Server on Linux. Roon tries to connect using SMB v2.1, v2.0 and v1.0 or fails to connect at all. I don’t know if having (additional) SMB v3 support (on the NAS) makes a difference at all for Roon Server running on Linux - I’m not that deep in the matter.

Hello @Stanislaw_Bochnak, and thanks for your feedback on our article! I’ll run this information by our team and see if we can get some more context on there.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.