Cannot access ROCK from Windows PC

For some curious reason, Windows has stopped allowing me to access Rock. Rock appears in Windows explorer but when I click on it, it comes with an error ‘Windows cannot access \ROCK’.

I have tried enabling SMBv1 client function, as suggested here

but this hasn’t worked.

I should add that Roon works from my PC, without any difficulty…

Does anyone have any thoughts?


Try rebooting both your PC and ROCK? (yeah, I know, but it’s worth a try…)

You say it stopped being able to access Rock, so it used to work, if so then has anything changed recently, firewall on pc, new anti virus sw?

1 Like

I also have the same problem after updating to the may 2020 update of windows 10.

Does this help?

1 Like

You might try: Going to the following Group Policy setting:

Computer configuration\administrative templates\network\Lanman Workstation

And “Enable insecure guest logons”

SMBv2 behavior was changed and no longer allows a user to connect to a remote share by using guest credentials by default, even if the remote server requests guest credentials.

This and making sure you have SMB v1 turned on. Windows keeps turning it off. So double check that as well.

I found that you if you go into the ‘Registry Editor’ of Windows and enable ‘allow insecure guest auth’ (the path of which is pasted below):

RUN–“regedit” as administrator

You basically double click on ‘allow insecure guest auth’ and change the value to 1 (I change it back to 0 when finished for security); then you should be able to access your ROCK network share.

Thanks everybody - Rugby’s solution has worked for me, I’m pleased to say. (I should add that I had turned on SMB V1 earlier - this is also required)

For reference, you access Group Policy by open Search in the Toolbar and typing Run (or select Run from your Start Menu) - then typing ‘gpedit.msc’ in the Run command and clicking OK.

Much appreciated


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.