Cannot access ROCK via windows PC

Hi there,

I am having a few issues accessing ROCK via my windows 10 PC. Up until now whenever I wanted to add music to my collection I would access ROCK via File explorer and then navigate to the Seagate HDD attached to the NUC and add the files accordingly. I have not had a problem before, although I haven’t added anything for a while.

The PC is connected to a switch via ethernet as is the NUC. Roon plays perfectly, and I can access the NUC via Chrome on I have tried restarting the PC and the NUC to no avail.

I previously had the ROCK shortcut on my quick access but now when I click on it I just get Windows cannot access \ROCK.

Can anyone help please?

@tahsu This may be the issue you have?
In the Fall Creators Update for Windows 10, Microsoft disabled SMBv1 by default as they consider it insecure. This is how the ROCK exposes itself on the network, so SMBv1 is needed.

It’s very simple to enable again. Scroll down to the third post here (second reply):


Thanks @Ratbert. That solved it! Fastest solution ever, brilliant.

Glad you are sorted.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.