Cannot activate USB Audio

I’m trying to activate USB for output from Roon. I got this in Settings/Audio:

(Separately, I don’t understand why DragonFly Red appears for the core machine. My DragonFly Red is attached to a Windows10 PC that is different from the Windows10 PC running Roon core.)

Hello @James_Antognini,

The most common cause of this behavior is running Roon from a backup made on another computer. Roon generates a unique identifier upon installation that allows other Roon-aware devices on your network to keep track of who’s who.

I recommend that you uninstall and then reinstall Roon on the affected computer. If this computer does not host your Roon Core/Database, you should be able to do so without worry.

I always recommend performing a Roon Backup before troubleshooting, so double check and make sure that you have a recent backup you can roll back to.


I first tried to enable from a computer other than the one where Roon core runs. Then I tried to enable from the core computer. And I just tried, on the core computer, to disable and then enable. Same problem.

I am reluctant to uninstall Roon from where it’s running (and has been running for a long time). I do not recall applying a backup to the core where the backup was made on a different computer.

Would a log produce any information?

Hello @James_Antognini,

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

In the meantime, it would be helpful if you could provide some more details regarding the issue you are seeing:

A. What computer are you using to control Roon?
B. What computer is the DragonFly plugged into?
C. Can you enable the DragonFly if it is plugged into the other computer?
D. What happens if you try to play to the System Output zone on the computer that you cannot enable the DragonFly on?


A. I mostly control Roon from a Windows10 Pro x64 PC that is different from the Windows10 Pro x64 PC running Roon core. But sometimes – today, for example – I use Remote Desktop to run the latter computer from the former computer.
B. Ordinarily (see next) the DragonFly Red is plugged into the former computer.
C. I just plugged the DragonFly into the latter computer and clicked Enable. Now (as seen on the latter computer) DragonFly has disappeared from This PC, and the DragonFly has disappeared from Antognini11B (the “former” computer). In short, no DragonFly Red anywhere.
D. On the latter computer (where until just now I didn’t have DragonFly), there is no sound output device. But I just clicked Enable on System Output, and I am told that “Audio will play on the default device” (whatever that might be).

Do I need to stop and restart Roon core for you to get logs? That is, core has been continuously active all today (and earlier).

Hello @James_Antognini,

No need to restart the core. It looks like they’ve already arrived. I’ve filled a ticket with the QA team for further analysis.


Hello @James_Antognini,

The QA team would like you to disable the Realtek Audio Driver on the MusicServer computer. The Realtek driver has a bug which prevents Roon from being able to see other audio devices correctly.

Additionally, they noted that Remote Desktop solutions will often try to re-route audio to the remote PC, messing with the audio subsystem of the PC under control. Try fully disabling the Remote Desktop software, rebooting, and then plugging the DragonFly into the PC (assuming you have Roon/Roon Server in your startup items).

It may also be a good idea to clear out the RAATServer cache on both PCs. To do this, stop any Roon instances from running and then type %localappdata% into the address bar in Windows explorer. You should see a directory labeled “RAATServer”, delete it.


I did all these things. I still fail (“Device Initialization Failed”) when I try to activate the USB Audio ASIO driver (on the system where Roon core runs).

I did succeed in activating the DragonFly Red on this PC.

Hello @James_Antognini,

What device is USB Audio ASIO Driver?


I have no idea what is the device for the USB Audio ASIO driver. According to System Information (Windows key/“sys” yields System Information app), these are the Sound Devices under System Summary/Components:

The Realtek driver remains disabled. Maybe it’s the Intel Display Audio device that lies behind the USB Audio ASIO driver. But ordinarily there is no physical display attached to this system (right now there is a physical display, since I started investigating without using Remote Desktop; but I’ve switched back to Remote Desktop when I found that the lack of Remote Desktop seemed to leave things unchanged), and Roon identified the USB Audio ASIO driver without a physical display.

You’ll have to tell me – from logs? – what might be the device behind the driver.

Hi @James_Antognini,

I would like to suggest a more advanced troubleshooting technique here, which is to re-generate a RAATServer instance.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location:
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Can you give that a try and let us know if it helps?

I still get “Device Initialization Failed.”

By the way, your instructions are a bit mangled: The second bullet says to navigate to Roon Database by opening Explorer, finding %localappdata% and finding/opening the Roon folder; the third bullet says to find the RAATServer folder, presumably under the Roon folder. In my case, however, the RAATServer folder is directly under %localappdata%; there is no such folder under the Roon folder.

Hi @James_Antognini,

In your previous post, you indicate that you successfully activated your Dragonfly DAC, which was the primary concern here.

Do you have any other USB DACs connected to your core? We are not exactly sure what the “USB Audio ASIO” driver is, it could be a previously installed driver for a DAC you no longer use.

The logs wouldn’t indicate what devices lies beyond the driver, but if you don’t have anything else connected other than the Dragonfly, then enabling this additional ASIO zone is not necessary.

I wanted to have Roon core supply music via USB output. Is that not possible?

Hi @James_Antognini,

As per your previous message you indicated that the Dragonfly USB is working properly, correct?

This is a USB output. The question here is what exactly is the ASIO zone you’re trying to activate? If there is no other USB audio zone plugged into to your PC, what are you trying to play to?

OK, I didn’t know what I was doing. (I can plead only that I thought Roon might provide a road map of how to proceed. But it’s my mistake.)

I just plugged a USB cable between the PC running Roon core and my pre-amp. Then I successfully activated the USB Audio ASIO driver, played a bit with its setup parameters, and finally had Roon delivering music to the pre-amp via USB.

Sorry for all the trouble I caused.

Hi @James_Antognini,

No trouble at all, just glad that we could clarify the issue :slight_smile:
Until next time, take care.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.