Cannot add albums to library [Ticket In]

Roon Core Machine

iMac Retina 5 K 27 inch Late 2015

OS: macOS Monterey 12.3.1
situation was the same in the previous OS.

Networking Gear & Setup Details

wifi 802.11ac

Connected Audio Devices

The situation is the same in the following audio devices.

  • System Output
  • Daphile
  • USB connected DAC (OPPO Sonica and so on)

Number of Tracks in Library

Description of Issue

I cannot add albums to library. After click button [+], image rounding again and again and looks like I cannot add album to library.

Qobuz App does work on the same computer properly. And add album to Qobuz library. However I cannot the same albums to Roon library in room app.

Not all the albums but some albums cannot to be added to room library.

The following operation did not work

  • reboot roon core
  • reboot audio device
  • reboot computer of roon core
  • clean up my library
  • log out and then log on Qobuz (because the albums I tried to add to library are associated with Qobuz.)

I also watched the following topic. Unfortunately it did not help me.

I also have the problem that I can not add albums to the library (at least it does not work reliably). After I click on the + button, the spinning icon appears, but nothing else happens.

This problem has been going on for a very long time. All possible fixes (e.g. switching DNS servers) do NOT help.

Really annoying!

Hey @yasu_naka and @ix400,

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem and need assistance please let us know.

If possible, can you both send over timestamps the next time you run into this issue? That way, we can have our technical team review your account to see what might be going on.

We’ll be watching for your reply and get back in touch as quickly as we can. Thanks! :pray:

A post was split to a new topic: Cannot add albums to my Roon library

Hello Benjamin,

I have just run into the same situation that I cannot add an album to my library.
What do you mean by timestamp? The current date is 2022-08-01 22:37 Japan Standard Time. I re-occur many times this situation regarding some albums.

Thank you!

Hey @yasu_naka,

Thanks for following up. This is a known issue we’re tracking, I’ll be sure to add your information to the ticket we have.

After you end up with an endless spinning wheel, are you able to see if the album does get added to your library (even though the spinning doesn’t stop?) Do you only see this issue when trying to add an album from Qobuz?


Same for me! it works only sporadically… may be 1 in 10 times.
And it is the same on MAC OS and iPhone 13 iOS


Same. problem here.
Roon core, NUC.

appx 5.000 tracks on SSD in NUC plus 45.000 tracks on NAS.

Network: ASUS mesh. HP switch, connected to ASUS satellite via ethernet.

Date. sep 3 22:15, 23:30, sept 4, 21:00 GMT.
Tested several albums.

The record will not be added to library from Qobuz. The icon is just spinning. If I go back one step and forward again the icon is not spinning and there is a + again. I can click the + several times, no different. It do not matter if I use iphone, ipad or my mac mini as remote.

Everything worked one week ago. Haven´t done anything since then.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.