Cannot add Network Share

I had a external music streamer and media server (NAD M50.2) which is Roon enabled as a network share which was working without any issue. I found that I could not connect to it today and when I removed it and then tried to add it back, I keep getting an “Unexpected Error” message.

Hi @Vikram_Shahi ---- Thank you for the report and sharing this observations you have made with us. The feedback is always appreciated!

Moving forward, to help aide in our understanding of the issue being reported may I very kindly ask you to please provide the following:

  • A brief but accurate description of your current setup using this link as a guide.

  • Has there been any changes to your setup that you can think of since noticing this behavior with the NAD M50.2?

  • Can you please confirm that you can successfully ping the IP address being assigned to the M50.2.


Hi Eric,

The NAD is connected to the network via ethernet. I can still see and access the NAD on my iMac and can drag and drop files into it. So it’s clearly “available” and “discoverable” on the system. I am also able to use the NAD to play music and rip CD’s and then drag the ripped files to wherever I want on my network using the Bluesound ios app.
So long story short is that the NAD seems fine and is freely accesable on the network except when I am trying to add it as a shared folder on Roon.
I cannot think of any reason for this issue but it was working fine till yesterday.
BTW, I have tried adding it as a shred folder using multiple devices, but to no avail.


Strange to say, I am having the same problem today with 2 setups that both are completely different from yours. I will be watching this thread closely.

Yep…very strange. Because the server is available on the network and I can read and copy files to other locations on the network. But Roon is unable to map the network drive. Had the same problem a few days ago but I removed the drive from Roon and then added it back and it worked. This time around, I keep getting an “unexpected error” message!

Ditto. FWIW, I am on build 276.

@Vikram_Shahi and @mitr ---- Thank you both for your feedback, the insight is greatly appreciated.

Moving forward, I am going to enable diagnostics on your accounts so our tech can try to get a better sense as to why you are experiencing this issue when adding a network share in Roon. Kal, would kindly please provide me with a brief description of your current setup, this way I have a better understanding of what you are working with.

Many thanks!

  1. Roon running on a NADAC+Player with control via MacBookPro.
  2. Roon running on a Win10PC with local control.

The two are running under different Roon licences and both trying to access files on the same remote NAS via SMB. However, both the MBP and the PC can access that same NAS directly or via JRiver.

1 Like

Hi @Vikram_Shahi and @mitr ----- Thank you both for your patience while our team has been trying to identify the cause of the issue you both are experiencing when trying to add a network share in the application.

Moving forward, as per the tech team’s requested may I very kindly ask you to please describe your network configuration/topology being sure to provide insight into any networking hardware you may be implementing in your setup. I want to have a clear understanding of how your devices are communicating and the “tools” involved with making these connections possible.


I have moved on since the issue seems to have been the contention between the two Roon instances. Shutting down one of the Roon programs eliminated the problem. Strange that there was no conflict between a Roon operation on one machine and JRiver on the other in accessing the same NAS.

Anyway, I did this only for comparison/review purposes, not a real-world application.

Roon core running on a 256 GB SSD on a QNAP TVS-682. The NAD M50.2 server and NAS are on the same network and connected using ethernet to the same router. I use Roon Remote on my iMac and iPad and I’m not being able to map the NAD using either.

Hi @Vikram_Shahi ----- Thank you for touching base with me and providing the requested feedback both are very appreciated!

Moving forward, I am going to be getting discussing this issue you are experiencing with the M50.2 today with the team to get some additional feedback and just to make sure I have all of your information correct in regard to your network. The only networking hardware in play currently ,is your router, correct? No additional gear?

Can you also provide the make/model of the router mentioned?

Many thanks!

Netgear Orbi. As I mentioned, I can see the NAD M50.2 and drag and drop files from it. So it’s clearly accessible on the network. But it’s just that I am being unable to add the NAD M50.2 as a network share.

Hey @Vikram_Shahi,

Can you share the address you trying to enter into the ‘Network share location’ input field ? Also, have you tried to reboot your devices ?
In regards to the fact that you are able to access the drive on OS level, are you sure that your OS is set to use SMB protocol when mounting the folder, because Roon can’t mount via AFP ? Here you can find instructions how to check that.