Cannot amend typo in track

I recently downloaded the 24/96 FLAC files released in 2017 of the remastered Bernstein: West Side Story with Te Kanawa, Carreras etc. Of the 27 tracks the title of track 25 has mistakes and is not in keeping with the rest of the albums tracks. Metadata however is correctly embedded so Roon is taking this information from another external source which is fine if only it would respect my edit of this track from within Roon. I know it’s only a small point but I like it right - any suggestions?

Goto the Album, then 3 dots, Edit

You will see metadata preferences, select prefer file for track name and Work Part


Thanks for the reply but that doesn’t work. As I stated in my post it will not respect an edit. The track title stubbornly stays the same. As an experiment I changed the preference to the file name of a track on another album and it works, proving that this is not a problem system wide purely this particular album - also any other track from within the album cannot be changed. Really don’t know why this album is reluctant to respect edits.

I would try removing it from your watched folder and then doing the Clean Up Library in Library Maintenance and then putting the files back.
This has worked for me when I can’t get Roon to show an edit/change in my files. Worth a shot.

You will be need to edit your Tags external to Roon, try MP3 TAG for example it’s free, Roon is simply not an editor. Once the Tags have been corrected, the Prefer File technique should work

Thanks for that but it didn’t work.

Thanks but there’s nothing wrong with the metadata - it’s perfect.

I suspect that is because Roon is not displaying a track title, but a work part title.

I think You could add your own Work/Part metadata and have Roon use that instead.

That’s correct.

This would work.

You could also submit a correction request here, which would help everyone (bottom of the box in the left column).


Thanks Joel. It would seem Roon is using this database for this album as the mistake is the same. Have made a correction request.
Finally got the track to display correctly by pointing Roon to a different variant of the five versions of the album available so that the album no longer identifies parts of the whole work - it’s just a straight ordered list of tracks without Act numbers. Problem solved. :grinning: