Cannot backup database from Mac to NAS

Mac Exteme Router - Netgear GS105 Switch- Qnap TS-473-8G. Ethernet Cable - Moon 390 - Moon 600i

Good Evening,

I have changed my Roon Core from Macbook Pro to my Qnap TS-473-8G. Everything works great except the backup of the database. I have made a couple of backups during last year and now when I try to get the data back it’s not working, all it say is “Did not succeed, please control your copy and try again”

What can I do?

Best Regards /Björn

This is how it looks like

Hi @Bjorn_Klockberg and welcome to the forum.

Try and stop at the RoonBackups folder. Don’t provide a sub-folder.


I have tried that also, with same results.
I think the problem is that I moved my backup folder from the Mac to my NAS. So when i try to do the backup there’s some files missing. I don’t have the files on my Mac anymore unfortunately.

Hello Bjorn,

Sorry to hear that you’ve had some issues restoring your backup after migration.

Can you please so into Settings>Backups>Find Backups>Select this Folder (see attached image below for reference) and send a screenshot of what you’re seeing?

This will help us determine if your backups were successfully copied over to your Qnap Server.


This is how it looks like.

Roon Backup 1

Roon Backup 2

Is there a reason why you seem to have selected the Download folder, rather than the RoonBackups folder? You may have been creating Backups in the Download folder in error?


That was just a default folder on my Qnap, no specific reason.
When I go to the RoonBackups folder it looks like the first picture i sent.

Hey @Bjorn_Klockberg

Looks like you able to successfully locate your backups, that’s great! What happens if you select and restore the latest backup?


Yes, I have located my backups, so far so good.
This is what happens.

In english: Backup failed, Please control your backup directory and try again.

@Bjorn_Klockberg I’m saddened to see that you continued to encounter difficulty with restoring your backups.

If this issue still persists would you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

Your logs will help us establish the cause of the restore failures. We appreciate your assistance with this, together we’ll get to the root of your problem.


Here is a link to my logs:

Hello @Bjorn_Klockberg,

I’m sorry we’re only noticing them today. I’ve looped in our technical team so they can take a look at your logs and come up with any possible next steps :nerd_face:

Please, sit tight :slightly_smiling_face:

Hi @Bjorn_Klockberg

I took a look at the logs here — It looks like the restore process is trying to find files that aren’t there. If you try older backup files do they work?

Inside of the RoonBackups folder do you see a file called roon_backups_root


No,they are not working. I have tried 5-6 different old backup files without luck.
Yes, I have the root file inside the folder.