Cannot connect Android remotes, only iPads

Core Machine (Operating system/System info/Roon build number)
Roon Server 1.7 Build 528 64-bit, running on desktop PC, Windows 10 Home 1909 64-bit.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon core connected to LAN by Devolo Magic 2 powerline mesh wifi.
3 other Devolo Magic 2 wifi nodes throughout the house, plus Devolo Magic 2 master node connected to internet. All interconnected by powerlines in the house.

Remotes: Apple iPad Pro iOS 13.4, Huawei P30 Pro with Android 10, older Android phones (Android 7, Android 8 etc).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound PowerNode, Ikea Symfonisk, SoTM SmS-200 etc.

Description Of Issue

I can only connect Android phones to Roon as remotes when connected by wifi to the same Devolo node as the Roon core is connected to by LAN. When connected by wifi to any of the other nodes, the phone cannot see the Roon core. Applies to my main phone Huawei P30 Pro, and all other older Android phones I have tried with.

But: iPad Pro connects without a glitch to Roon when connected to whichever wifi node.

The issue has been persistent through several Windows 10 builds, Android updates etc.

Hi @Ole_Jakob_Fogstad,

Thanks for reaching out.

In the past, we have seen issues surrounding powerline adapters, and as such we suggest not to use them if at all possible, as mentioned in our Networking Best Practices guide.

Android devices are a bit more susceptible to multicast issues, and often times powerline adapters have a poor multicast routing implementation, so we generally suggest a mesh-style network if direct Ethernet runs are not possible.

What you can do to possibly improve the communication in your current setup is the following:

  1. Take a look for any IGMP Snooping / Proxying options on the Powerline adapters, IGMP settings have helped so I would try to toggle these on if avaliable.

  2. On the “Choose your Core” screen, you could try pressing the “Help” button and manually inputting the IP address of your Core or the multicast broadcast address of

  3. Assigning a Reserved IP address in your router configuration for both the Cores and the Remotes.

Thanks for your quick reply to this issue @noris.

As for your suggestions:

No such options on my powerline adapters as far as I can find.

Using the multicast broadcast address seems to do the trick! Thanks!

1 Like

Happy to help @Ole_Jakob_Fogstad!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.