Cannot connect as remote to core - appear to be running two cores on same account [Resolved]

I’m running core on an Intel NUC with music stored on a QNAP NAS. I often run two MacBook Pros - let’s call them MBP13 and MBP15 - as remotes without any problem. I often take the MBP13 away from the house on trips and when I do I deauthorise Intel NUC as core and use the MBP13 as core with music stored on a 2TB USB drive. I also occasionally do the same thing on the MBP15. I have had no problems switching core between the various machines to date - indeed it is one of the many joys of Roon. I recently took my MBP13 on a trip and now it will not act as a remote to the Intel NUC. My MBP15 is behaving normally.

When I try to connect the MBP13 as a remote to the Intel NUC I get the standard choice screen asking me to “Choose your Core”, but the choice given is between the MBP13 (“This Mac”) or the MBP15 - the Intel Core is not listed even though it is the active core. The MBP15 is listed as a choice even though it is connected to the Intel Core as a remote. Something appears to have gone wrong between the authorise/ deauthorise handshake routine. My MBP13 will not act as a remote to the Intel NUC Core but it will act as a remote to the MBP15. There is no problem with the MBP13 acting as core. I believe I am able to run two machines as core at the same time on the same account. The only event I noticed is that there was a software upgrade (build change) during the period this problem emerged.

What do I need to do to fix this problem?

Only if you have 2 licenses, I believe.

Sounds like it thinks it is the Core, I suggest clicking the disconnect from Core option … then you can try connect as remote.

Also worth trying is to shut all the cores and remotes down and then bring up the the core of your choice first.

Daniel - yes I agree I shouldn’t be able to run two cores on one licence but in this odd configuration that is exactly what is happening.

Carl - I tried all those things before posting. No joy. This is a really odd one. I think I need some technical help to remove all Roon software and start again on MBP13.

Let’s tag @support for you.

Hello @Enduser,

Let’s try and get this fixed. To start, lets try manually signing out on both of your macs to see if that gets things back in order. What you’ll need to do is disconnect from your NUC (at least on the MBP15), press “This Mac” on the “Choose your core” screen, then Settings > Account > Sign Out. After completing these steps, I would also restart the NUC device. Let me know if this helps.


I had already done all of this before I posted but I have just done it again.

All three machine now re-booted and running Roon. Core is the NUC.

MBP15 can connect to core as a remote to the NUC core (this is how it is configured this minute)

MBP13 cannot see the NUC at all (it can see the MBP15 as a core but cannot connect to it as it as the MBP15 is currently running as a remote to the NUC.

My suggestion: remove Roon completely from the MBP13 and re-install clean.

Thoughts @support

Hello @Enduser,

Let’s try resetting the Roon database on both MBP’s, this method will be just as if not more effective than a full reinstall. To find the Roon database folder, follow the instructions here. When you’ve located the Roon folder, simply rename the folder to “roon_old”. The next time you open the application, it will create a new fresh database to work from.



Still no joy. Having done as you suggest and upon opening the Roon application and opting to run as a remote I get the Roon Logo with “LOOKING FOR REMOTE LIBRARIES…” alongside the logo but it will not connect to the core. The new Roon database folder has been established.

Hello @Enduser,

Could you try power cycling your NUC and router? Looking at your most recent logs from the NUC, it reported seeing a new device on the network around the time that you started your new Roon database, but it wasn’t able to establish the connection.


1 Like

Thank you John - recycling the router did the trick.

1 Like

This topic was automatically closed after 23 hours. New replies are no longer allowed.