Cannot connect Nucleus to Eero

Core Machine (Operating system/System info/Roon build number)

Brand new Roon Nucleus (just opened the box)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Eero Beacon

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue

I unpacked my Roon Nucleus out of the box and plugged it into the Eero beacon (which is part of my home wifi system, and connected to other devices by wifi).
The Nucleus does not show up and cannot be found by Roon software on my phone or laptop (both connected to the same Eero via wifi).

The light under the port of the Roon blinks green a few times after I plug it into the Eero but is then solid green. Help!

Coleman, here are some troubleshooting tips if your Nucleus core is not being found. One thing to check: as the Ethernet LED is not blinking green, it suggests you are not having any data transferred by the LAN. While it may sound silly, try another Ethernet cable. The one you are using could be damaged.

Nucleus not showing up in “ Choose your Core ” or “ Configure Roon OS ” screen

  • Confirm that your Nucleus has been turned on. The white LED above the power button should be lit.
  • Confirm that your ethernet cable is plugged into the Nucleus and that the LEDs on the ethernet port are on and blinking.
  • Confirm that your ethernet cable is not damaged or dysfunctional
  • Confirm that your Roon Remote is connected to the network. WiFi is fine, as long as it is the same router as your ethernet network.
  • In a multi-LAN or subnet setup, auto-discovery will not work. You can locate the Nucleus’s IP from your DHCP server (your router most likely) and enter that IP into the remote via the " Why Can't I see my remote Libraries? " link.
1 Like

Hi @Coleman_Kendall,

Welcome to the forum!

@Flashman provides some great tips towards getting started, but I would also suggest the following:

  1. Make sure that your Nucleus is up-to-date on latest firmware:

  2. Confirm you have turned it on, pressing the power button once should start illuminating the port.

  3. Check Roon Settings -> Setup -> Configure Roon OS devices -> Configure to see if it by any chance shows up there.

I would also suggest looking over the Nucleus Manual as it’s a great tool to get started, but if you have any specific issues or have tried these troubleshooting steps and are still stuck, just let us know!

Many thanks! A bit of fiddling and it was on line.

Another question: It immediately told me that a software update was needed (my phone has 1.7 and the nucleus 1.6) and it’s been allegedly downloading without making much progress for around 90 minutes. Anyway to check if it’s stuck and restart?

I’d reboot. Just a thought.

Hi @Coleman_Kendall,

An update shouldn’t take that long, I would also suggest rebooting the Nucleus. You can press the power button once to power it off and then press it once again to turn it back on. Or alternatively, you can use the Web UI to perform the reboot.

Many thanks to all; for whatever reason, trying to get the phone app to update the Nucleus kept failing, and using the laptop version worked just fine.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.