Cannot connect Nucleus to Synology NAS

Win10, Nucleus

Synology 214+

Hi, I am trying to switch from running my roon account from my laptop to my new nucleus. The laptop had no problem accessing my nas but i cannot connect from the nucleus for either the library or the backup.
I have tried multiple combinations including:\iTunesMusic

but i just keep getting “There was an unexpected error”

I’ve tried to follow the online help, specifically this:

but when I right click to properties on the nas folder, I don’t have the “sharing” tab

I have a Nucleus connecting to a Synology DS216j.
I have my music in a folder with that name on my NAS.
I use \\SynologyDS216j\music as the storage watched folder link in the Nucleus settings.

hmm, i thought it might have worked when it thought about \DS214+\iTunesMusic for a while but then failed again. same with \SynologyDS214+\iTunesMusic
thanks anyway
-edit- all my double slashes are also getting changed into singles in this chat-

Hello @john_taylor1,

Can you check to see if you can see the Nucleus over the network from your Windows 10 machine? Check in file explorer and make sure everything is visible, then we can build up from there. Let me know!

yes i can see the nucleus in file explorer but when clicking on it i am asked for credentials

Sorry that had no success for you. It is maybe a setting needs updating in the NAS.

I remember updating a setting or two in the NAS Control Panel, File Services, SMB and its Advanced Settings. Sorry can’t remember the detail now.
It is probably worth googling for info on SMB settings in a Synology NAS.

cheers, in that location it tells me to address it as \Diskstation214, so i tried that but still the same roon error

if i search in explorer for the stated ip address of the nucleus, i am taken to a web page with the nucleus settings and it all looks ok

and if i search for backslash, backslash(nucleus ip) i get asked for network credentials, but i don’t know what those would be in this case?

Try Guest.

From FAQ: I’m having trouble setting up my NAS:

this shows where i have made sure that SMB is enabled on my NAS and the name it recommends i search for:


This shows me accessing both the nucleus and the NAS from my windows machine:


here is the error i get when trying to connect the nucleus to my NAS either for library or to restore from the backup i prepared from my previous core on my win10 laptop:


I get the same error with multiple paths:






I have tried every combination I can think of and sometimes it seems to search for a second or two but it always gives the same error unless I type something incorrectly when I get the error: “Invalid Network Path”

mine is

1 Like

thanks a bunch, i re-tried \nasname\music
after a restart and it now works. thanks all!

Hello @john_taylor1, glad to hear things are up and running! Let us know if you need help in the future.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.