Cannot Connect Remotely

I have Roon setup on my late 2015 iMac and the music files are on an external hard drive connected directly to the iMac. I am trying to connect to my library from my iPad Pro but the app is unable to find my library. Both devices are connected to the same WiFi. The iMac is also connected via internet. I also have a QNAP NAS but have not used in for my Roon setup. Any suggestions?

In Roon, did you go into Settings>Setup and make sure Accept Connections from Remotes is clicked to On (blue)?

This may help you troubleshoot.

Cheers, Greg

I had already checked that. Still no luck.

Hi @tomdee55 — My apologies for the slow response and the trouble here. Thank you for describing your setup, that information is extremely helpful in our evaluation of issues. May I kindly ask you to please confirm the following for me.

  1. Are there any active firewalls on network?

  2. Are you making use of a VPN configuration?

  3. Can you confirm that the IMac and Ipad have IP addresses in the same range (ie


Eric, I am using an active firewall but have allowed access to Roon. I have never used a VPN but would be interested in understanding how to setup and use. Would you please provide directions for that or point me in right direction? I checked the IP addresses and they were different so when I had the iPad Pro scan for libraries using the iMac IP address it worked. When I tried the same thing on my iPhone 6 Plus, however, it did not work. Should it work on my iPhone?
Another issue I had is when I did the initial import of my about 8000 albums, Roon imported a lot of tracks by themselves instead of combining them on the same album. I’m also missing a lot of my album cover art. Anyway to easily update to fix these issues?
Thanks for your help, Eric!

Hi @tomdee55 ---- Thank you for the feedback / update. Let’s break this down one thing at a time.

I would strongly advise against trying setup a VPN before addressing these other issues :slight_smile: It appears that there is already some sort of communication error going on here over your network (i.e the iphone not connecting) and I believe that should be our starting point here.

Can you clarify for me, if you were able to confirm the IP address on your iPhone? As mentioned in my previous post is it in the same address range as the other devices (IMac and Ipad)?


Now I cannot connect with my iPad again! The time I connected I manually put in the iMac’s IP address. Several hours when I tried again I cannot connect. iPad says “Waiting for Remote Core”. All three IP addresses have the same first seven digits ( The last two digits are different (.10,.17 and .18)

@tomdee55 ----- Thank you for following up with me and apologies for the continued issue here. Can you confirm for me if your core is in a sleeping state at any point throughout the day? Thanks!


don’t know how to determine that…

Hi @tomdee55 ----- My apologies. Let me expand further on my thinking here. If your core machine is going to sleep while remotes are actively communicating with it, those remotes will lose connection and control over the core machine until it is woken up again.

For example, when I use my Mac book pro as my core I control it via my Android phone while I am home listening to music. In order to ensure that I don’t lose connectivity from my android device I have set my MBP to never sleep (example below).


I use my iMac as the Core. I believe I have it set so that it doesn’t sleep. Attached are by settings for your review. Also, Can I connect to core from my iPad AND my iPhone at same time?

Eric, I’m sorry but I’m about ready to give up on Roon once again and return to Sooloos! I consider myself somewhat technically savvy. This shouldn’t be so difficult…

@tomdee55 ---- I completely understand, and can respect your frustration here. I am certain we can get to the bottom of this issue and get you back into a stable state.

Thank you for the screen grab. Your computer is indeed setup to not go to sleep :+1: I wanted to make sure I confirmed and eliminated that potential variable from this problem. Your clarification is immensely appreciated!

In regard to your question, about your apple devices. You most certainly can use both devices to control your core.

My feeling is that there is something going on with your network that is causing these devices to drop off and lose connection with the core, being as you’ve confirmed that your core is never in a sleeping state.

Can you give me some more information about your home network configuration and the hardware being used.

  • How are things communicating? (Wifi?) (Hard patched via ethernet cable?) (Both?)
  • What hardware is being used in your setup? ( Type of Router(s)?) (Any repeaters?) (Any extenders?)

I also think we should re-confirm that everything is in the same IP range again to be extra certain that everything is communicating properly. You can use an app (free) like “Fing” on the iPhone to scan at home networks looking for devices that it can see showing up its self in the process.


My devices are communicating on WIFI network. I used Fing as you suggested and I can find my core (iMac) on both iPad and iPhone. My iMac is connected via both WIFI and hard patched via ethernet cable. My router is an ZyXEL model #VMG8324-B10A. I do have a Gigabit switch connected to router but the iMac is connected directly to router.

Hi @tomdee55 ----- Thank you the follow up and the confirmation. I will be contacting you via PM momentarily to gather some more info from you. Thanks!