Cannot Connect Roon ARC to Roon Core 2.0

Roon Core Machine

Mac Book Pro 13’ 2017, Intel Core i5, 8GB RAM DDR3,

Networking Gear & Setup Details

Router wifi IDU-300, 5Gh,

Connected Audio Devices

Argon Audio Solo

Number of Tracks in Library

7500 tracks,

Description of Issue

cannot Connect my Roon ARC (Android Samsung Galaxy S22 Ultra )

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“37.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Welcome to the Roon Community

Have you got anymore spec info on your router.

Is it a mobile data one?

Hi @Krzysiek_Starsky.

To help would you be so kind to answer the below questions?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Thx.

Maarten.

Hey @Krzysiek_Starsky,

Are you still having issues connecting to Arc? If so, please fill out @Maarten_Duits’ questions :pray:

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode