Cannot connect Roon to Tidal anymore

Roon Core Machine

QNAP TVS 671 with Intel i5 and 16GB RAM
Roon Core 1.8 (build 850) on dedicated SSD 970 EVO 250GB PCIe SSD card

Networking Gear & Setup Details

Swisscom Internet Router 3, 2 Netgear Switches

Connected Audio Devices

Linn Majik via LAN, Macbook Air/iPad Pro and iPhone via WLAN. Roon App 1.8 (build 831)

Number of Tracks in Library

18600 tracks

Description of Issue

Not able to connect Roon with Tidal since 2 weeks with all devices.Roon and Tidal user since several years whiteout any issues. Library access to core without problems. Can play any tracks on the library stored on QNAP.
Tried several times to connect Roon with Tidal under Settings/Services with existing Tidal account. Roon opens Safari and after login to Tidal confirms that I am successfuly connected to Tidal. Hit the window to open and return to the menu Services where I am asked to connect to Tidal. It’s like a loop.
Please help me to get this problem fixed.

Problem solved.

Needed to update QNAP QTS firmware to build 20211119 which has been published yesterday, November 22.2021.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.