Cannot connect Ropiee to CXA81 DAC

I am unable to connect my Ropiee device to my CXA81 integrated amp via USB.

identifier: 673b6d8e8836c71a

Best I can get is for the device to show up on Roon intermittently. However, it is unable to play music or stay connected for longer than a few seconds.

Setup is: Roon core on mac. Ropiee on RPI4b connected via wifi. Ropiee connected via USB 2.0 to the CXA81.

Please help. I have tried everything. (multiple usb cables, multiple resets, flashes, re downloaded software etc.

Thanks.

I already sent you a private message, but for clarity (and others to follow) here’s my response again:

The CA devices are notoriously difficult to drive over USB. That being said, there are 2 things here:

  • your logs are flooded with messages about a possible faulty USB cable. I have never seen this messages before, but it would not hurt to try another cable.
  • I’ve recently released a new kernel in the beta channel to address a few USB issues. It might be worth it to try this out. Switching to the beta channel can be done in the ‘advanced’ tab. It will require a few reboots (one after switching to the beta channel, another one after pulling in the updates).

Let me know how it goes.

Thanks

here is a big thread about CA implementation of USB Classes

Admittedly before they went Roon Ready just recently , I have a CXN V1 which you can see gave me grief

Hi Mike,

Thanks for your reply. With the help of Harry I managed to fix the issue. I had to accept a drop in quality from 192khz to 96khz but I am fine with that if I can avoid bluetooth. It is a massive step up.

the issue was fixed like this:

The problem seems to be with the 2 classes of USB audio the CXA81 can handle. It is set to handle Class 2 by default, but the RPI doesnt seem to handle

To change it to class 1:
put the amp in standby mode.
hold the “speaker a/b” button until the speaker lights flash alternately.
deselect “a4” (make sure the light is off)
Hold the “speaker a/b” button again to save the changes.

This is all from the manual. (which I never read until it was pointed out to me.)

Perhaps this can help someone else as well.

Yep

That’s the essence of that other post, I went through the same logic with Harry. It seems a mismatch between CA’s Class 2 USB implementation and Linux in Riopeee. Its less obvious in older CA kit as Class 1 was the default you had to do the twiddles to activate Class 2 not the other way around.

I got around it by adding a CoAx Allo Digione but that in essence makes the CXN Redundant

Small nuance here: it’s not a mismatch between ‘Linux in RoPieee’, but Linux in general.

There are still quite a lot of hardware manufacturers that don’t bother testing their hardware on Linux properly and make sure it goes beyond a merely “we support UAC on Linux”.

On top of that, most DAC vendors don’t make it possible to upgrade the USB firmware (yes, the USB chipset has firmware as well). If that would be the case things like these can be solved quite easily (as well as native DSD support for that matter).

No offence meant :grinning:

Hehe. Non taken!

But I’m getting a lot of questions about these matters so I only wanted to clarify a bit.

Thanks!

Just an opinion , i have 2 options USB , Coax,

One uses the RPi, the other adds in the Allo Digione . Both feed an Audiolab M-DAC

In your example of the Mutec to do the heavy lifting , which of the 2 option, all else being equal, would you choose. The Async USB ? Or Spdif

Been considering buying a CXA81… Was class 2 ever fixed for this device with Ropieee? Or does changing the amp to class 1 mode remain the fix?

I never got an answer from CA support about the CXN, I even asked them recently about the new DAC magic 200

The reply was “Linux is not supported”

Unless someone has tried it I don’t know but I guess NO

I got around it by adding an Allo Digione so I could use SPDIF for 24/192

Unfortunately CA is one of those companies that still does not get it wrt USB.

It works here with class 2 usb.
Ropieee on Rpi4 connected to the usb of cxa81.

1 Like

Does 24/192 work via USB? How about 32/384?

Yes, it does work.


1 Like

Thank you so much for the confirmation!!

No problem, enjoy the music!

You sound like mi girlfriend :sweat_smile: