Cannot Connect to ARC after Updating to Build 1143

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

After ARC was released I always can successfully connect to my core via ARC.
I do not manually configured any manual port forwards except that I used the port 9229, and it just works.
However, two days ago after updating from Build 1133 to Build 1143, I cannot connect to core via ARC anymore. No matter how I changed the port number, it keeps showing this message
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“143.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

After tinkering with multiple solutions, this keeps happening.
I am wondering if I can downgrade back to Build 1133 to see if it is the build’s problem.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router. Since this was working, you may want to try rebooting your router, core and any other network equipment you have.

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thanks.

2 Likes

2 posts were split to a new topic: Issue Connecting Via ARC

Hi @SthMax,

I wanted to check in on this issue, as it’s been some time. Were you able to connect to ARC on Build 1143 in the interim?

We just released a new build of Roon/ARC. I recommend updating to the latest release (notes here) and then attempting the automatic port forwarding configuration again. We’ll be standing by just in case.

Thank you!

Hi, thanks for the follow up. I have updated immediately, and the problem still persists with exactly the same message:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“143.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

In my case, I am directly connecting to my college’s network without a modem / router and the network assigned a static public IP address to my computer. But when I use Online Port Check Tool, it seems that all of my ports are closed. I am not sure if it is a firewall problem, I will check it soon.

Doesn’t seem like my pc’s firewall problem, I have reset / turn off the firewall but the problem still persists.

You are in a situation where your access is being limited by the network policies of the school. You might have to have their help in getting this setup. Have you tried to contact them?

Hi @SthMax,

As @Rugby mentioned, logs show your network provider is applying some filtering that will prevent your Core from reaching ARC. Have you had a chance to contact to reach out to the school’s IT team to illuminate what enterprise-grade security is in place and whether it can be configured to allow port forwarding?

I thought so, I had sent an inquiry to the school IT and still waiting for replies.
What really troubles me was that when ARC was out, I could use it without any problem and I do not think the school had changed their network policies since then.

Seems like my school totally bans port forwarding / port discovery.
I have circumvent it by setting up zerotier, works perfectly for both Roon and Roon Arc.
Thanks for the help anyways