Cannot Connect to Nucleus+ server

Roon Core Machine

Nucleus+ server
Windows 10 running on Dell XPS8700 desktop

Network

XB6 modem connected by ethernet cable to Netgear 8 port gigabit switch (GS308), connected by ethernet cable to TrendNet 8 port gigabit green switch (TEG-S82G) which is connected by ethernet cable to a Nucleus+ server.

Connected Audio Devices

EtherGen switch (with attached After Dark Clock & linear power supply)
Devialet Expert Pro 220 integrated amplifier
NAD M50.2 ripper/server/music player.
(all ethernet cable connected)

Number of Tracks in Library

125,000

Description of Issue

When I try to use Roon to connect to my core Nucleus+ server, the following mesage appears:

“Network error. Please check your internet connection”

I used a computer technician to try to solve the problem and he went to the Roon Community online information for help.

Ethernet cords were replaced, the Bitdefender firewall was disabled, power was recycled on the devices etc. but the technician could not solve the problem.

My network provider confirms that the internet is working properly and my browsers are able to connect to the internet on my computer.

On the Roon community website I found, but have since not been able to find, some references to recent Windows 10 updates possibly being the source of this problem.

Can anyone help me try to solve this problem?

On your Windows 10 PC, have you configured the Windows 10 firewall to allow exceptions for roon.exe and raatserver.exe per this guide:

Can you connect to the Nucleus Plus with a phone or tablet using the Roon mobile remote application? Also, what version of Roon is your Nucleus Plus on, 1.8 Legacy or 2.0, and is your Windows PC on the same version? Roon needs the Core and all Remotes to be on the same version after Roon 2.0 was released.

Robert;

In answer to your questions:

  1. yes I have configured Windows 10 firewall & BitDefender to allow an exception for Roon.
    2 trying to use my iphone to connect results in the same message so it also does not connect to my Nucleus+.
  2. both the Nucleus+ (core) and my Windows PC are on Version 2.0

Did you or your technician check the Xfinity xFi Advanced Security too? Also, is your internet access over IPv4 or IPv6?

As other users reported issues with it in the past and published technical specifications imply that this switch partly isn’t compliant with current networking standards, please try and remove this switch at least temporarily from your setup and see if it helps.

Seems to be an ordinary (or probably not so ordinary but still a) network switch to me. Bears the question how all this is connected together?

All in all, is this a new installation or did the same devices in the same configuration previously work for you? Do you probably use other security software/devices (proxies, Pi-hole, …) that affect your internet connection?

If you turn off your Nucleus+, unplug the network cable on its back and plug the same cable into a PC or laptop instead, can you access the internet, the Roon website and your Roon Account using that cabled connection normally without issue?

1 Like

BlackJack;

I don’t know if the technician checked XfinityxFiAdvanced Security also , but I canno find it on my computer.

I removed the following ethernet switches

Netgear 8 port gigabit switch (GS308)
TrendNet 8 port gigabit green switch (TEG-S82G)

and replaced them with a Linksys (SE4008) switchc & a Linksys (SE2008) and it made no difference.

My post contained a link. Following it you could have found: Getting Started With Xfinity xFi Advanced Security - Xfinity Support.

Hey @Greg_Johnson,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I wanted to see if you were able to give @BlackJack’s suggestions a try? On a similar note, I’d love to see how things function if you connect your core directly to your router, bypassing all network switches.

I’ll be on standby for your reply :+1:

BlackJack;

You asked: If you turn off your Nucleus+, unplug the network cable on its back and plug the same cable into a PC or laptop instead, can you access the internet, the Roon website and your Roon Account using that cabled connection normally without issue?

I did all of that and yes I can access the internet, the Roon website etc. using that Ethernet cable without issue.

Benjamin;

You said that you “love to see how things function if you connect your core directly to your router, bypassing all network switches.”

I have been delayed trying other remedies because of the following:

  1. My Windows 11 DELL XPS8950 desktop finally came just back this week from DELL where its repair was delayed by a shortage of parts.
  2. I am waiting for a new ASUS router that is scheduled to arrive next week. ASUS also had no spare parts so they are sending me a newer router. I will bridge my existing modem to this new router.
  3. I previously obtained a new modem from my internet provider.

With this new modem, none of the servers, music players etc. on my Ethernet wired home network show up on either my old DELL Windows 10 XPS8700 desktop computer or on my new Windows 11 DELL XPS8950 desktop computer.

Does anyone think that this modem might be the reason why, when I try to connect to Roon, the message appears that there is an “internet connection problem” ? Is it possible that the IP address ranges used by the modem are incompatible with the IP ranges assigned to the devices on my home network? If so how do I correct this situation?

Yes.

How are the IP addresses assigned, did you setup each device to use a static IP address?

If so, reset your devices to use a DHCP

1 Like

In an attempt to stop getting the message " Network error: Please check your internet connection" that I keep getting when I try to connect to Roon, I repaired or replaced the following components:

Dell finally repaired and returned my relatively new DELL XPS8950 Windows 11 desktop computer. Shaw (my internet service provider) had also replaced my modem & ASUS replaced my router with their GT-AX11000 model.

I replaced two ethernet switches and the ethernet cable going to my music system, with a CAT 8 ethernet cable. I had a computer technician remotely control and try to resolve the problem, to no avail.

I still have no solution to my problem of trying to connect to Roon.

Hey @Greg_Johnson,

Thanks for the update!

Before anything else, can you check the firewall settings on the new Dell? Please review your system firewall settings to verify that both Roon.exe and RAATServer.exe have been added as exceptions. Reboot the device if just adding them in.

After enabling diagnostics on your account, I’m not seeing your Nucleus+ online. Are you able to power on your Nucleus+ and access the web UI? I want to make sure your core is online so we can focus in on the windows remote.

What model modem has Shaw provided you with? We’ll need to put that into bridge mode. Make sure either UPnP is turned on with the new router, or create a manual port forwarding rule using the port number under Roon Settings>Roon Arc.

Here is a step-by-step on port forwarding for your Asus router: How to Port Forward an ASUS Router | Support | No-IP Knowledge Base

Let me know :+1:

Benjamin;

Firewall settings (BitDefender) have allowed an exception for Roon.

I am able to access the Roon web UI.

Shaw modem is XB6 and was bridged to the ASUS modem.

I could not get past step 4 on the port forwarding instructions for the ASUS router i.e. the Port Range.

Therefore I had a technician look at my home network & computer again but he ran out of time and had to leave. He did not think that port forwarding was necessarily a solution because, if I got this correctly, he said that we are dealing with an internal home network not an outside one. In any event he said that he would have to know which port number Roon was using.

He was trying to analyze my home network using software such as Wireshark but Wireshark was so unbelievably slow in downloading that he had to leave before it had downloaded. He left me with instructions to try to use Wireshark to try to analyze what was happening when I was trying to connect to Roon, but Wireshark would not work. It came up with the message:

“the capture session could not be initiated…(failed to set hardware filter to promiscuous mode. A device attached to the system is not functioning. (31)). Please turn off promiscuous mode for this device” Since I know virtually nothing about networks and this sort of thing I don’t know how to do this. The technician had wanted me to convey the Wireshark analysis to the Roon community for advice on what to do, but obviously I am unable to that.

He also told me that although, when I try to connect to Roon, a message comes up that there is an internet connection problem, there is no internet connection problem for other devices. He was also unable to reset the Nucleus+. He therefore suspects the problem is with the Nucleus+ server.

Do you have any further advice before I call the technician back to my home?

Hey @Greg_Johnson,

Thank you for the detailed information above. I’d like to keep things a bit more simple here, I don’t think it’s necessary to bring Wireshark into the picture. Arc’s framework might be a bit confusing to a technician who isn’t familiar with Roon, so I can see how they might think port forwarding isn’t relevant. However, port forwarding is going to be the only option for setting up Arc.

Basically, if Arc doesn’t auto-connect when UPnP is activated, then setting up a manual port forwarding rule is the way to go. In fact, if you haven’t, I would disable UPnP if it doesn’t connect out of the box, as there can be hiccups if both UPnP and a manual port forwarding rule are both active.

This is a good first step!

You can find the port number you are using in your Roon Core settings> Roon Arc. Roon uses port 55000 by default (and what my settings are set to,) you can put this number for both range increments. You can also pick a different port if you’d like. Feel free to use any available port in the 10,000 to 65,000 range.

I see that you’re also using Xfinity Comcast, please turn off ‘Advanced Security’ as this has been known to cause issues with Arc. Read more here : “Are you online? Please check your internet connection and try again" [Solved Xfinity firewall] - #49 by David_Ohm

Let me know how the above goes :+1:

Benjamin;

This afternoon the technician visited my home and followed your instructions regarding port forwarding, including disabling UPnP, and they did not solve the problem of not being able to connect to Roon. What now?

Greg

Hey @Greg_Johnson,

Taking a step back and looking at your account, it appears that your Nucleus+ hasn’t been online since 11/2. Is this correct?

Plug it into a monitor via HDMI and let me know what you see. I would also make sure the Nucleus is plugged directly into your router. Let’s also try to avoid any network switches for now as well :+1:

Let’s also give your Nucleus+ a hard reboot too. I’ll be on standby for your reply

Benjamin;

I am not sure how long it has been since I have not been able to connect to Roon.

I did follow your instructions and plugged in an HDMI cable between a monitor and my Nucleus+ server. The following message came up on the screen:

"Manufacture: Roon Labs
Model: Nucleus+
Serial: It gave the serial number
Host Name: Nucleus Plus

Roon can be accessed by opening and Roon remote product. If you don’t see this device then check “Roon OS devices” on your network. Roon OS Web UI can be directly accessed at (It gave the IP address)"

Following your instructions:

  1. I unplugged the ethernet cable, which connected one Ethernet switch upstairs to a second Ethernet switch downstairs. If was into this downstairs Ethernet switch that my Nucleus+ & my other music devices were plugged .
    2, As you suggested I instead ran the same Ethernet cable directly from my ASUS router to my Nucleus+ server.

I then tried to connect to Roon and it worked.

Do you have any thoughts as to why my previous setup would not allow me to connect to Roon? I had previously replaced both switches with brand new ones but this did not solve the problem and I kept getting the message “Network Error: Please check your internet connection” .

Greg

Benjamin;

I turned Roon off and then tried to connect to it again. It is now not connecting again & once again coming up with the message “Network Error: Please check your internet connection” What do you think is going on?

Hey @Greg_Johnson,

Odd indeed! We’ve seen plenty of network-based issues dealing with switches in the past. Primarily it’s managed switches that cause the most problems. We have a decent help article around networking best practices which may be helpful:

If you were able to get things up and running bypassing the switch, I would configure it that way again, and give your router/network a hard reboot to see if things connect properly again. Generally speaking, it does sound like a network problem preventing you from listening to your music.

Jot down the date and time the next time this issue occurs while you troubleshoot, and we’ll take another look into your system diagnostic to see if anything specific may show itself :+1:

Benjamin;

I tried the following scenarios and here is what happened:

Scenario 1. Dec 2/22 1:45 pm

  • Ethernet 8 cable connected directly from ASUS router to Roon Nucleus+
  • Rebooted ASUS router
  • Tried connecting to Roon but it would not connect.

Scenario 2

  • Ethernet 8 cable connected directly from ASUS router to Roon Nucleus+
  • Ethernet 7 cable connected directly from ASUS router to downstairs Ethernet switch to which all my music devices are connected (except for the Roon Nucleus+ which was connected as above)
  • At 2:05 pm I rebooted my DELL XPS8950 desktop computer
  • At 2:07 pm I rebooted my ASUS router
  • AT 2:10 pm I tried logging into Roon. After about 2 minutes of trying to log in the message came up “Add your music”. Under “Choose music storage folders” I added a new folder for my NAD M50.2 music player (has FLAC music on it) using \192.168.50. —\shared". Eventually a message came up" “Are you online? Please check your internet connection and try again.”

Do you want to take a look at the system diagnostic?

Greg