Cannot Connect to Tidal anymore

I came back home yesterday after a week to find that I cannot connect Tidal to Roon anymore.

I tried on my computer and phone. I log in the usual way, prompt it to open in Roon, but it doesn’t update in Roon and I can’t access any of the content.

1 Like

A post was split to a new topic: TIDAL in Roon shows “Nothing Playing” but albums are visible

Hey @James_Muller, thanks for bringing this to our attention!

How are your router DNS servers configured? We have seen users have a better experience in the past if they change their DNS servers to Cloudflare (, Google ( or Quad9 ( Can you please change this and let us know if you’re still experiencing the issues?

Additionally, what type of router are you using? I’d recommend comparing your router to those listed in our Networking Best Practices article to see if certain settings on the router are interfering. The article will explain which setting to change based on the model/manufacturer of the router.

Thanks! :pray:t3:

Hi Ashley,
To your first point, I’m not sure I understand what I have to do. My DNS is configured to a static IP: I haven’t changed anything there, so I don’t understand why all of a sudden it should stop working using the exact same settings. In my router, those settings are locked as well, so I can’t change anything. I’m also not signing up to a 3rd party software just to get this to work. If that’s the only option then I’ll go elsewhere.

I’m using a Segemcom Router, which is not listed in the link you sent.

I unpugged with router for over 15 minutes to reset it and have it generate a new IP. I can still access the Roon Core fine via my browser, and sometimes Roon detects it, but I now get “Are you Online” error. I tried troubleshooting via this page:

Because I got a loading database error. I looked at this page:

I don’t understand the solution. Roon is allowed through my firewall. My core is being detected fine now, I’m stuck in this endless screen for reasons beyond my understanding. The entire message reads:

“Your account needs to be quickly confirmed, then you’ll be all set. Please check your internet connection and try again.”

I’m connected to the internet on all my devices.

Hey @James_Muller words escape me when I think of the words to say to apologize for the delay in my response; please accept my sincerest apologies for not getting back to you sooner.

I wanted to check in and see if you were able to move past this error within Roon? This error, “Your account needs to be quickly confirmed, etc.”, can happen if your Core machine is having trouble reaching our servers. Often times it’s from a firewall or something like that blocking the connection, but it can also stem from other networking issues.

If you’re still experiencing issues when connecting, could you please provide us with a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

In addition to this, we’d like to take a look at the logs to see if we’re able to determine what is causing this error.

Could you please use the directions found here and send over a set of logs to our File Uploader?

Thanks so much!

I posted elsewhere, but I’m now getting the exact same error. The ROCK is detected all well and good, but I can never get past the panel where I enter my credentials

It’s not my credentials that are the issue, since I get an error if I type them wrong. After about a half minute of waiting I get the following error:

My core doesn’t get detected on my either my phone or my partner’s phone.

I’ve tried everything so far, including a fresh reinstall of Roon Rock after wipping the hard drive clean and I’ve reset my modem twice, once to factory settings. What’s puzzling is that I haven’t changed anything in my setup to get that issue. After reinstalling Roon Rock, I got prompted for a software update on my computer and the ROCK, which seem to have worked fine.

It appears in my modem’s control panel just fine, with the right IP, I can connect to the ROCK by typing in the IP, and I can access the hard drive from my PC. I was advised to change my DNS settings, but it’s unclear to me what to do exactly. Plus, in my modem, the DNS settings are locked. My router is not listed in your troubleshooting list, and without any further assistance on the DNS issue, if that is indeed the cause, I’m out of ideas. I’ve now wasted about a whole day reinstalling things and trying to apply smaller changes based on what I could google and I’m gradually not finding it worthwhile anymore. I haven’t been able to use Roon for over a week and half now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.