Cannot delete - File in use?

Roon Core Machine

Windows 10 (Model, i5 something!, 8GB) –

Networking Gear & Setup Details


Connected Audio Devices

Topping MX3

Number of Tracks in Library

240,000 tracks

Description of Issue

For several months I have not been able to delete any albums (mostly things I find that are duplicated).

I thought that the storage on my Drobo N had become critically low.

However, adding a new drive has not solved the problem.

Have you tried to quit Roon Server and then use the regular Windows File Explorer to delete files?

It is a good thought … and … no I have not … because that is very much harder work, particularly since using Roon my file labelling has been much more lax, and combined with this, I am often trying to delete the non-preferred version. BUT! You are right, I should try it just as an exercise to gather information though, maybe, nothing else.


Yes, it is much harder work to find and identify the file. BUT Windows deletes the file through File Explorer without blinking.

That says it is a Roon problem, doesn’t it?

It means that Roon was accesing your files at the time you were trying to delete them. That shouldn’t be happening all of the time so, yes, it does sound like something odd is going on!

This means that another process has a lock on those files, so Roon cannot delete them. Do you have an antivirus scanner or backup running from time-to-time?

You are right Martin. I just can’t fathom what … or why … or how to find out … I need to do a bit more research …

On the specifics … I only use Windows Defender these days … and One Cloud is backing up.

Thank you for bringing some clarity!

I have learnt some things. Resource monitor! In ‘Associated Handles’ a search for Roon reveals only a couple of Microsoft registry files, but they are being accessed by Roon itself. Mmm?

This topic was automatically closed after 20 hours. New replies are no longer allowed.