Cannot delete TIDAL albums added in the library

I am using both Qobuz and Tidal services
Roon installed on Nucleus +

I cannot delete Tidal albums added in my library
I get a message that these tracks cannot be deleted because they were either not found or you don’t have permission to delete files from the hard drive
After that the albums cannot play and no track info is shown (album not in library) although the album is still showing in the library !!

Qobuz and Locally stored albums can be deleted

Best Regards
Andrew Economides

Hi Andrew I have always deleted my Tidal album’s using the Tidal app. Not sure if this is an API issue or not.
If you delete them in Tidal and refresh them within the Room App they disappear.


Hi @Andrew_Economides,

Are you able to add tracks and albums to your library okay using TIDAL?

Were these tracks added as Track Favorites in TIDAL or an Album Favorite?

Thanks for the replies
@dylan I am able to add albums to my library from TIDAL

I used to have a TIDAL subscription in the past and then moved to Qobuz, and reactivated yesterday due to a new three months offer. So the first time i logged in again in TIDAL from Roon it automatically added all my TIDAL favorites in my
library and faced this problem

Today i shut down and reboot ROON and the deleted albums disappeared from the library.

But the problem continues, if I try to delete either a track or album i get the same error message etc

The problem was solved a bit unexpectable!
I am using a Melco N10 as a streamer ( has also a 3TB HDD used as a part of my library) and Roon endpoint and i have given the Melco a fixed IP address and somehow the nucleus when rebooted was given the same IP address (which is a bit crazy i don’t know how it happened), I changed the Nucleus IP to a static one and the problem was solved !!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.