Cannot find core when connected via router, but can via access point

Core Machine (Operating system/System info/Roon build number)

Windows 10, Intel NUC i5, Roon 1.7 (build 521 64 bit) (Roonserver)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TP LINK VR600 (router), TP LINK RE220 (Access Point). Roon Core connected direct to router via Powerline

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218

Description Of Issue

My Roon Core is located in my study, whilst 218 is in Living Room (co-located with router). When connected to router via Wifi in living room, my Samsung S10 cannot find Roon Core. When in study and on Wifi via Access Point, Samsung S10 can find Roon and play back music in the living room (??).

I have checked subnet/turned off firewall/forwarded UDP+TCP ports but with no joy. I don’t understand why it works perfectly via Access Point but not via the router. Have inspected wifi settings on router and can’t see anything obvious.

Can anyone advise next steps? Thanks!

I am having a bit of trouble understanding the topology but wanted to suggest using the same SSID on your router and access point.

Also can you confirm that your entire network is on the same subnet?

Yes, everything is on same subnet and I checked that using Fing.

Topology is:
Router (with 218 attached) - > powerline - > Roon Server

I know the powerline works as Internet is fine on the NUC running roon server. I can also control Roon and the 218 perfectly from the wireless access point that is in same room as roon server.
I tried renaming the SSID on AP to same as the one on router but no joy.
I also note that I can’t remote access my NUC when in living room able.

(Note this all used to work perfectly until I had to change router…)


Hello @Boru80,

Based on your topology and the behavior you’re describing, my first guess would be that your router isn’t forwarding multicast traffic from the WiFi interface to the ethernet interfaces.

I would check the LAN settings on the router to see if you can disable IGMP snooping. If this doesn’t work, I’d try to get my hands on a different router for testing to see if replacing the router resolves the issue.


Thanks John - I’ve disabled IGMP snooping but no joy.

I note I can’t use Remote Desktop connection either when on same wifi as router, if that is any clue.

I will try and swap out the router for a BT Homehub later (which I suspect will work). There’s a setting/something not right with the TP Link… :frowning:

Hi @Boru80,

I suspect that the powerline adapter might be causing some of the problematic behavior here, we have seen reports surrounding powerline adapters and we generally suggest to not use these kinds of devices in a Roon setup as they often don’t properly pass multicast traffic.

If possible, we would suggest a direct Ethernet link between the router and any access points. If a direct link is not possible, mesh-style networks such as Orbi/Velop/Google WiFi have had the best results in other Roon setups.

OK…so I eventually noticed that wireless clients connected directly to the router could not see any wired LAN clients (i.e this was a network problem, not a Roon problem). I have tried every setting under the sun and googled everything but with no joy.

It seems this TP LINK router is duff.

I have solved the problem (temporarily) by moving my wireless access point to my living room, and controlling Roon that way. But I’m going to need to get a new router :frowning:

Thanks for the help though!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.