Cannot find remote RoonServer library [Remote Connection]

I’ve got Roon installed on a Windows 7 laptop. Until today, it was my only Roon install. Today I upgraded it to V1.1, and I copied the Roon directory to another device running Win 8.1. On the Win 8.1 device I renamed the Roon directory to RoonServer, and then installed RoonServer on that device. RoonServer is now running on the 8.1 device, as evidenced by Roon icon in my system tray.

On the Win 7 laptop I’ve gone into the Setting, under the General tap, and clicked Disconnect under the Library heading. That brings me to a “Chose your library” screen, where I select “I want to use this PC as a remote control”. That leads to a Chose your Library screen, that has an icon saying "Looking for remote libraries… ", and it never finds anything. And in the “Why can’t I see my remote libraries?” dialogue box, I’ve supplied the Win 8.1 device IP and device name. Neither works. Though if I supply an invalid device name, it tells me so. Which tells me it sees the Win 8.1 device. Just not connecting to the library there.

These two devices are on the same Ethernet segment. Firewalls are disabled on both devices. Each device can ping the other, either by IP, or by device name.

Any advice?

I believe there us a setting with roon server to set whether it is discoverable by remotes, check this is set.

Thanks, but it doesn’t have an interface. No GUI. So not sure how you would do that… It’s supposed to be configured with connected remotes, as I understand it.

Maybe you have found a bug. If the Roon app setting before you renamed the folder had Remote Access switched off … then maybe RoonServer is acting upon it.

As a test / workaround try this:
Stop RoonServer and rename the RoonServer folder back to Roon and fire up Roon app.
The use that to check / set the Remote Access setting.

Then shutdown Roon, rename folder and start RoonServer… and retest with a remote.

Thanks for the help, but I can’t try that. I did not want to cloud the subject by taking this on a wild goose chase, but it seems I must. Here goes…

I can’t start Roon, because it’s not installed on the Win8 device. It had been long ago, but I uninstalled it because it never worked on that device. That’s because it does not have the proper OpenGL version. And that’s because while it’s Window 8.1, it’s running as a virtual machine under Oracle Virtualbox on a Linux machine. And the virtual machine that Win 8.1 is running under only has OpenGL 1.1 installed. I’m trying to correct that, but until I do, Roon will not run on my Win 8.1 device. Bummer.

That said, EVERYTHING else works on this Win 8.1 install. And there are zero network issues that I can find. So RoonServer SHOULD work. But isn’t.

Thanks for the advice, and if I can get the VM up to OpenGL 3.X I’ll do it and report back. But that’s proving tricky…

Hi again,
Running inside a VM may be significant.
How do you have the Oracle Virtualbox networking setup (NATed, Bridged, …)?

Firewalls, you say disabled on both devices. Are there not 3 devices (remote, Linux and Win8 inside the VM)?

I’ll do some checks on my setup to see if I can shed anymore light on the Roon settings.

Thanks. I’ll grant that running inside a VM MAY be an issue. It’s running a bridged adapter. And you make a good point - there are indeed 3 firewalls. But let’s not jump too quickly to point the blame there, as everything is in-line for this to be working. Here are the salient facts:

  1. The Linux (VM host) firewall has been turned off.
  2. The Win 8.1 Windows Firewall (for both Public and Private networks) has been turned off.
  3. The Win 7 Norton 360 (used instead of Windows Firewall) has been turned off.
  4. The two Windows machines can ping each other using IPs.
  5. The two Windows machines can ping each other using host names.
  6. The two windows machines can access the shared folders of each other.
  7. From a network scanner it’s clear that the Win 8.1 device has TCP ports 9100 and 9101 open. I mention that only because 91XX is what RoonServer is supposed to be using now (or so I understand).
  8. Other than the lack of OpenGL 3.3 support, this Win 8.1 machine runs all the applications installed on it perfectly, including applications that move data back and forth on my private network, and over the Internet.

Other than the fact that the RoonServer is not discoverable by the Win7 machine, I can see no reason to think that this is a network issue. And the fact that it’s running in a VM appears to be just coincidental. Though I do understand why one could jump to the assumption it was the problem.

True detailed instructions for setting up RoonServer have yet to be released. So I was hoping maybe someone might see the things that I did in the install, and suggest something that I might have done wrong.

Thanks for the help.

Have you tried completely removing Roon from your Win 7 laptop, including the Roon folder and then reinstall the software as a remote?

I know it should work how you’ve done it, but that might be a bug? The fact that a copy of your data is still on the laptop, might be causing a problem,

I’m no expert, just offering a suggestion.

Cheers, Greg

Thanks. I’ve taken that suggestion and one-upped it. Rather than just deleting the Roon on the Win 7 laptop, I deleted both Win7 Roon and Win 8.1 (VM) RoonServer, rebooted everything, and reinstalled. Beginning with RoonServer on Win 8.1.

To my delight, when reinstalling Roon on Win7, it had no trouble at all locating the Win 8.1 RoonServer, and allowing me to set the Win7 Roon up as “remote”. But after pointing it to the network drives where I store my music, the Roon install merely show that cute half circle with the moving lines “wait” symbol. And on the RoonServer box there’s lots of IO, CPU and network activity.

Now I think I’m going to have to be patient, and give it an hour or 10, and see if it works. I’ll report back either way. Again to all - thank you for the help.

Thanks Carl. That’s great advice. Could have been exactly what I needed. Possibly useful for others, as you say…

But it’s all working just fine for me just now. So what made the difference? Not sure. But for anyone with a similar problem, please contrast what I described in my first post (that resulted in the problem), and what I described in my most previous post (that corrected the problem - at the cost of losing my prior install).

FWIW I suspect this whole thread will be of little value after the folks at Roon Labs write up solid instructions on how to do this correctly. Until then… good luck setting up RoonServers. Maybe my documented missteps will help someone.

Thanks for all the help folks! :smile:

Hey @scolley – just seeing this, and sorry for the trouble here.

I have a feeling Greg’s advice above was correct , for what it’s worth:

I think you had been running Roon on the Win 7 PC, and then copied the database over to the new PC and launched it there. Then you launched Roon on the original Windows 7 PC, so you were probably running the same database on both machines, which will cause all sorts of problems.

The instructions allude to this, but maybe they need to be a little clearer.

Let us know if you have any more problems @scolley or if I’ve misunderstood anything above. Thanks!

Thanks Mike. I read the instructions. Many times. IMO they need to be a lot more clear (more detail). Particularly with regard to migrating the database from another machine, and changing that machine to a remote.

Though the fact that multiple core instances was bad, was indeed very clear, Yet the direction I got in that same thread seemed to get around that. But I followed that direction, which did not work. Thus this thread…

Thanks for chiming in.