Cannot find Roon Core (Nucleus)

I am using the Roon Nucleus as Core and have multiple Apple devices as Remote. Since I switched off and back on the Nucleus some days ago, the Roon Core can no longer be found,
The Nucleus is powered on, white, orange and green LED are all on. I have checked the cables, and made zero changes to Operating Systems on my Apple devises, Wifi and Switch. I have tried connecting to Roon Web, but ‚Configure Roon OS devices on your Network‘ also keeps searching without any success.

How can I get my Nucleus back online ?

Are you able to connect a monitor or tv to the hdmi connection to see what’s displayed?


I am having the same problem on my Nucleus+. After the most recent update I could not find the core. Waited a number of hours and then power cycled, hard shut down, and also hooked up a working HDMI cable and get no signal. The power LED is white and the network port LEDs do light up and flicker after it’s been ‘booting’ a while. In the list of connected devices on my switch I don’t see its MAC address or activity on it’s port.

Just connected a Monitor and am getting:

Yet at when trying to directly access Roon OS Web with the IP address shown, I cannot connect.

That probably means that you are using a web browser on a device (PC, Mac, tablet or phone) that is on a different subnet…

Can you give some more details about your networking setup?

I am using an Apple iPad and also an iPhone as Roon Remote, accessing my Wifi which is from an Apple Airport Extreme (in Bridge mode). The Airport Extreme is connected using an ethernet cable with the Router provided by the company where I have a DSL subscription (Wingo in Switzerland).
The Roon Nucleus is connected using an ethernet cable with the same Router.
I have other Switches in my home network, but have deliberately made sure both the Airport Extreme and the Nucleus connect straight with the router.

I have also just checked the IP addresses of the Airport Extreme the iPhone and the iPad: they all are 192.168.0.xy

Hey @Kaspar,

Following up on this thread, have you tried resetting the network settings on your Nucleus? That should help if not. This can be done by connecting the Nucleus HDMI output and a USB keyboard and typing ENTER resetnetwork ENTER.

For more info, you can check our KB here:

I’ll be monitoring this thread for your reply :+1:

Just tried and am getting:

I should add that I unfortunately still cannot find my roon core with the roon remotes

What happens if you press Enter on the keyboard? It should probably reboot, and what is the message then?

When I press enter, it just shows the original screen, but the problem persists.

I just launched RoonArc on my iPhone. Interestingly, it does find my Nucleus yet indicates ‘poor connection’.

Hey @Kaspar,

After re-reading this thread, have you tried completely power cycling your network and router (power down and unplug for a few minutes), as well as your Nucleus?

I would first give this a try let me know if your Nucleus is still giving you errors :+1:

Hi Benjamin,
I have power cycled all the remote devices, the nucleus, and all the network gear just now - the problem persists.

Hey @Kaspar,

We’re unfortunately still not able to see your Nucleus online. Are you able to pull up the WebUI? If so, I would perform an OS reinstall.

If not, you’ll likely need to perform a fresh Roon OS install via a USB drive. Please start on step #3 and follow the steps to reinstall via a USB drive here:

Note that you’ll need to plug in a keyboard into the Nucleus to boot from USB. I’ll be on standby for your reply :+1:

Hi Ben,

I’ve launched the nucleus a couple of times from the USB drive with the downloaded file - I am always getting the same screen while booting (both when launching from the flash drive or normally):

And when done:

But I cannot find the Nucleus with any of my devices, nor directly using the IP address.

This is getting somewhat frustrating, I must say.


Hey @Kaspar,

To confirm, you’ve properly flashed the new OS onto a USB drive? With that, did you hold down the F10 key on your connected keyboard right after turning on the Nucleus? Continue to hold the F10 key down until you appear at a menu that asks you which device you’d like to boot from.

If the above doesn’t help, and you cannot reach the webUI, then you may need to send in the core for repair via an RMA. When did you purchase the device?

I have flashed the new OS onto the USB drive with Ether. Only observation here is that the file ending is .img and not .img.gz.
F10 to then select the USB drive to boot also works. I then get the above screens. Are these screens the correct ones, or do you expect anything else displayed ?
Because I just rebooted all the devices and also the router / internet, double checked again all IP numbers and redid the whole process: same outcome, it cannot find the Roon core.
I did buy it on February 5th 2021.

Hey @Kaspar,

There is a chance that a bad or failing SSD is preventing you from flashing the OS. Just to be sure, you’re only using one router, and one subnet across your network?

And when you type in into a browser window, what do you see?

As a last test, you could bring it to a friend or family member’s house and try to connect using their Network to test to see if the issue is hardware on the device or something in your network.

Unfortunately, this means the device is no longer under warranty, and so there would be a fee associated with shipping the device to Roon for repair.

Hello Ben,

Indeed only one router, and all devices are on the same subnet.

On the warranty: as you can see, this thread goes back to January 11th. So I do hope you will reconsider your position.

I have contacted my dealer on the return.