Cannot find Roon Core (Nucleus)

Forgot to add: when I type the IP number into my browser, I get “cannot connect to the server”

That exact message? What is your web browser?

Edge will give this message:


While Google Chrome will give:


Can you post a screenshot of what you are seeing?

Ah, OK, you’re using Safari on your phone. Out of interest, what’s the IP address of that phone?

It is

This is all very odd, and I can understand that it must be frustrating.

  • The Nucleus is reporting that it has a network address in the same subnet as your phone.
  • The LEDs on its ethernet port are alive (presumably the orange LED is constant, while the green LED flickers indicating network traffic?)
  • You’ve tried different cables, with no change to the issue.

Last suggestion: have you tried a different port on the switch or connected the Nucleus directly to a port on your router as a test?

Yes, the LEDs are on, green and orange.
I have alternated all the ports and cables indeed. I have just now also set up the Nucleus and my phone at the neighbors house, i.e. different router and network - am getting the same result: the roon core cannot be found.

Could you swap the router for a test? Apple Airport isn’t exactly state of the art.


It’s a hardware issue, I’m afraid. These incidents are increasing to such an extent that I’m beginning to wonder.

1 Like

Agreed. And thanks for pointing out.
That device likely has some hardware issue.

1 Like

Hey @Kaspar,

Thank you for giving the above a try, especially testing the Nucleus on another network. It does seem to be hardware related if you were not able to get it online in this case.

You beat me to my next question here. I’ll leave this thread open in case you have any additional questions. Following up with your dealer is the correct next step. :+1:

This topic was automatically closed after 45 days. New replies are no longer allowed.