Cannot find Roon core unless server started in RDP window [Resolved]


  1. Everything was working correctly until most recent Roon update.
  2. On remote computers (and Android phone), Roon cannot find Roon core.
  3. Connecting to Roon server via Windows Remote Desktop on remote computer allows Roon on remote computer to connect to core.
  4. If Remote Desktop connection is closed or minimized, Roon on the remote computer loses connection to core.

Troubleshooting steps already tried:

  1. Roon install is set up to accept connections from remotes.
    2 Have turned off firewall on both computers, restarted both computers; problem persists
  2. No anti-virus programs are installed
  3. Both computers are on the same network, and have the same network settings.


Roon core and remote setups are identical:

Operating System: Windows 10
Firewall status : Windows Defender firewall, enabled (also tried without fireall)
Network connection is ethernet
Roon for Android also does not work unless Roon Server is started on a remote computer

Network configuration:

AT&T portal device for internet access and wi-fi. No internet access problems on any computer.
Computers are connected via ethernet through a Cisco 24-port switch
Computers can see each other through Windows.
Library is on NAS attached to core; both computes can see it

Any help would be appreciated!

I’ve seen some odd issues when disconnecting RDP sessions, but these have mostly dealt with device access being closed when a session is disconnected even though the session is active…

Try this:

  1. Open an RDP session and verify that you can connect to your Roon core from a remote.
  2. Open a command prompt on the machine running the Roon core.
  3. type: tscon 1 /dest:console

This will disconnect your RDP session and redirect it back to the computer’s console. If this works then it means that Roon is likely accessing a device that it put into limbo when when the session is disconnected.

Are you running full-blown Roon on this machine rather than RoonServer? If so then this may be related to the graphics device “disappearing” when the RDP session is closed. That leaves the session in a state of limbo until you reconnect. Why this would have worked before and not now is a good question, but Roon is very graphics device sensitive, especially on Windows.

If you are running RoonServer then there’s some device that RoonServer is relying on that’s going into limbo when the session is disconnected.

I’ve had some odd issues using Roon with RDP, but never had an issue with RoonServer in that setup.

Andrew P:

Thanks for the quick response.

I ran the tscon 1 /dest:console command on the Roon Server computer from the admin-level command prompt, and it did cause an immediate disconnect.

If by “full-blown Roon” you mean the version that functions as both a server and an endpoint simultaneously, yes, that is the configuration on the computer I’m RDP-ing into, and it has been working fine until yesterday.

It appears that the RDP connection is only needed to get Roon remote going; once it is going I can play different music, start and stop playing, etc—in other words I have full control. I am however unable to start Roon again after stopping it, unless I RPD into the Roon Server computer again.

Oh, I should also mention that if the computer running Roon remotely goes into hibernation, or if even the screen goes dark, the music stops playing.

Hope this helps.

John Gallup

Are you running full-blown Roon on this machine rather than RoonServer? If so then this may be related to the graphics device “disappearing” when the RDP session is closed. That leaves the session in a state of limbo until you reconnect. Why this would have worked before and not now is a good question, but Roon is very graphics device sensitive, especially on Windows.

Tried disconnecting from the (headless) Roon Server computer with the graphics device up, and with it minimized: same result. Remote computers can’t access the server unless it’s running in an RDP window

RDP can be tricky because it works at a pretty low level – it takes control of audio drivers, graphics drivers, network configuration, etc, and causes issues for OpenGL, which we depend on in many configurations, so we generally avoid mixing RDP and Roon when possible. (many of us use TeamViewer which is much more lightweight).

Anyway, just to be clear, if you leave RDP out of this scenario completely and turn off all firewalls, your Remote doesn’t connect? Are these two machines able to ping each other?

Just want to make sure we separate some of the known pitfalls of RDP from general connectivity issues – it’s possible something about RDP is giving our discovery protocols a nudge here, but we might make more headway looking at why that’s not happening normally than trying to work around some of the known issues with RDP.

Also, I’m going to enable some diagnostics on your account so we can take a deeper look at this. Can you give us a rough timestamp to look for when this happened:

if you’re not sure, go ahead and run the test one more time, and then we’ll know more about what’s going on here.

1 Like


Turned off firewall on the machine running Roon Server and the machine running Roon Remote. When I started Roon Remote on the remote machine (w/no RDP going), I got the “Roon is still trying to connect…” message, which never goes away.

When I RDP’ed into the Roon Server machine, Roon came up immediately on the remote machine, as before.

Yes the machines can ping each other.

To be clear: RDP is not the cause of this problem. When things are running right, RDP is not used. RPD is in a sense the solution to the problem, because it’s the only way I can get Roon running on a remote machine.

One other wrinkle that may be helpful: I use a Win 10 laptop to control Roon in another location. It has the same hangup, but in addition, Roon stops playing when the laptop goes into “Sleep” mode. The remote machine connected by ethernet does not exhibit this behavior.

I believe this problem began about 22 November, but can’t swear to it. I know it was a few days before I first posted about this problem here. There’re no date stamps so I can’t tell exactly. What’s frustrating is that everything worked fine with this setup until then.


Thank you for the follow up and insight @John_Gallup! As Mike mentioned in his post, he has enabled diagnostics on your account which should help us try to get a better sense as to why you are experiencing this behavior with your devices.

Once I have some feedback from our techs I will be sure to follow up with you ASAP. Thank you agin for your continued patience!


1 Like

When you say they have the same network settings, you mean they are on the same network subnet, or that they have the same IP address?

Different IP addresses on the same internal ethernet network. is the Roon Server has Roon remote

Hi John, just some thoughts…

I still think it would be a good test to setup either TeamViewer or Splashtop, on the Roon Server and use that to remote in instead of RDP.

If it works just like RDP does, i.e. lets other things connect to the Roon Server, then that is a good data point.

If it doesn’t work like RDP and remotes still cannot connect, then it will let you look at things on the server in a non-working state.

Alternatively, you could move the Roon Server to a location with a mouse and a keyboard to see what is happening on the server in a non-working state.


Installed TeamViewer on the Roon Server and the remote box. Got the same result: Cannot start Roon on the remote until the Roon Server computer is connected via Team Viewer.


Hey @John_Gallup – I think Rugby’s suggestion here is good:

Roon can only run when the user is signed into Windows. Are you confident your computer stays logged in when you disconnect?

Connecting a mouse and keyboard would be a good way to confirm what’s going on on this computer when you’re not connected remotely – if the user is being signed out, that would expect why Roon is no longer running.

Perhaps this KB article is relevant…

There’s a very good chance that this is the issue. When Windows 10 starts up the “console” session doesn’t start until a user logs in with a local keyboard / mouse or a user is automatically logged in. An RDP connection to the machine without a console login never allocates certain resources beyond the RDP session. Disconnecting the session puts those resources into limbo and although RoonServer may still be running as a process it may not be able to talk to the outside world.

I believe the problem is solved, and thanks to all for thoughtful and helpful suggestions. The solution was to use the ntplwiz command on the Roon Server box to cause autologon, and then to go into the registry to set the same function and supply logon name and password.

Congrats on the solution. Was there a reason you did run Roon Server on the machine instead of Roon?

It’s both the server and a an endpoint. Works just fine now that it doesn’t wink out on me.

Awesome, enjoy John!

This topic was automatically closed after 30 hours. New replies are no longer allowed.