Cannot get audio thru to Logitech Duet via HQ Player

Hello Roon folks,
I had this problem once, solved it without knowing how, and now have it again. Using Roon on a Lenovo all-in-one running Windows 10. Setup went fine, imported library from my NAS, downloaded HQ Player using Roon prompt. Typed in the Network path from HQ player to my Squeezebox Duet, named the zone “living room”. I was able to play files in my computer room but when I tried to send files to my living room I got the error message “Transport: Couldn’t connect to HQPlayer”. I am using a Netgear wireless router sending the signal to my Samsung phone and a Lenovo Thinkpad. Somehow I had this problem fixed by adjusting some settings in the Settings section but I cannot remember what I did.

Is the Squeezebox Duet an HQ Player NAA (Network Audio Adapter) ? I couldn’t see that it was from a quick look online.

If not, then you won’t be able to send audio from HQ Player to the Duet over the network directly. You will need an NAA for HQ Player to see.

Roon itself, however, should detect the Duet as a Squeezebox Zone if you have turned on Squeezebox Support in Settings. This will be a different zone to HQ Player.

If the Duet is an NAA and HQ Player is running on the Lenovo with Roon, then enter “localhost” rather than the Duet IP address for Roon to find HQ Player. HQ Player should then find any NAA (you may need to restart it).

1 Like

The Duet is not a NAA. This cannot be done.

1 Like

Thanks bobflood.

@kim_hixson you can enable Squeezebox support in Settings/Setup as below:

This will enable Roon to see the Duet as a Squeezebox Zone, but you will be limited to 24/48 playback.

I don’t think HQ Player is useful with the Duet as I think the DAC in it is limited to 24/48.

1 Like