Cannot get Nucleus+ to power up

@support Cannot get my new nucleus+ to power up. New purchase was up and running for 3 days-- with all features working (Core, owner installed SSD, USB out to DAC, Database update, audio zones, HDMI out etc.) but can no longer get it to power up. Not even a green light when a known to be working LAN cable is connected. Have undone set-up and down to working wall power outlet and working LAN, but no go. Have taken (supplied) barrel power adapter out of the equation – no go. Tried using laptop power cord into barrel adapter (as an alternative power cord) – no go. Suggestions? Thanks.

Return it to where you bought it.

Hi @Greg_Harding,

Does the light for the power button light up at all?

Was there anything specific that occurred leading up to the Nucleus not working? Did you try a different power adapter or was there a power outage?

If you connect the Nucleus to a monitor via HDMI and power it up does anything display?


Thanks for the reply Dylan. Alas:

  • The power light does not light up.

  • Nothing specific. Had been working fine. No change in power adapter. No power outage.

  • Tried connecting to a working monitor via HDMI (with power adapter attached). No signal.

Thanks, @Greg_Harding.

I’m passing this information along to our technical team for next steps. I’ll be sure to update you as soon as I’ve received their feedback.

Hi @Greg_Harding,

Please try the following with the device:

  1. Unplug your Nucleus from the AC outlet and wait for about 15 minutes.
  2. Press and hold power button for ~30 sec few times. Do this with no power source connected to make sure the Nucleus discharged completely.
  3. Connect Nucleus to the AC outlet and try to turn it on.

Let me know if there is any change after this.


I have the very same problem today … any suggestions

Hi there.

I heard the steps set out below from Roon support and I tried them and they worked.

"Often times we find that a reboot will resolve this type of issue, but since you’ve already given that a try, let’s try the following:

Find and open your Roon database

Navigate to Roon/Cache

Move the contents of the /Cache folder elsewhere, like your desktop

Try restarting Roon and verify if the issue still occurs"

Thanks for the revert, I cannot get the Roon Nucleus started, the white light does not come on. Opened the screws and see that the orange and green lights are on. Not certain what to do next. Thanks

How do I open the Roon database if Roon Nucleus is not Powering on ?

Alas, I am of no assistance on that.

Thanks Greg. How did your problem of Powering up get solved. Did the 15 min wait and discharging work for you. Thanks

A post was split to a new topic: Nucleus will not power on

This topic was automatically closed after 2 days. New replies are no longer allowed.