Cannot get roon remote to run on a win 10 PC

(Mark Inboden) #1

Core Machine (Operating system/System info/Roon build number)

Win 10 PC Core I7 4770 32GB Ram NVidia GTX1060 / Roon Core / roon 1.6 (build 416) Stable(64bit)/ ethernet defined to roon as MARKS-MUSIC-SER

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

arrakanis network wifi and ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Win 10 PC Core I9 7920, 64 GB Ram, Nvidia GTX 1080, realtek HD audio / Roon / roon 1.6 (build 416) Stable(64bit)/ ethernet

Description Of Issue

I am trying to run roon remote on a networked win 10 core I9 PC to play on my PC’s speakers. I install roon and it has me select MARKS-MUSIC-SER as the core but I cannot find and/or define any output zones on my PC. Is there a way to run roon and output to my PC’s speakers (the Realtek HD Audio). Or is that not a valid roon device?

My output devices disappeared again
(Daniel Beyer) #2

Try temporarily turning off the firewalls on your remote PC and see if the audio options appear. If they do then you know you have to add exceptions for Roon, RoonServer and RAATserver in the firewall.

(Mark Inboden) #3

Thank you, I just tried it disabling the firewall on the Roon remote PC (the one I want to use to play through the PC’s speakers ). I stopped and restarted Roon on remote PC and no new output zones appear.

(Scott G) #4

Can you share a screen shot of Settings>Audio from the remote PC?

(Mark Inboden) #5

Sorry I meant no new audio sources appear. I actually just tried it again and noticed when I first started Roon it said the Realtek HD Audio (the Audio Driver for the remote PC) was connected directly to the core. After about 15 seconds it disappeared. I then attempted to refresh the “Connected to this PC” it has been running for 10 minutes and occasionally flashes some options and then they disappear again and it just says “refreshing” . It cycles so fast I cannot read anything. I let it run for 20 minutes and it finally quit flashing options and the “refreshing” box just kept satying refreshing. I exited out of it and now the options for “connected to this PC” is no longer listed.

(Scott G) #6

You may need to reboot the core on your Win 10 PC Core I7. There is obviously something flaky going on with how it’s finding (or not finding) audio resources on your remote PC. It should find several audio devices.
For now, be sure the Windows firewall and any antivirus programs on either machine are turned off. Once you reboot the core machine maybe the audio device discovery will be more robust.

(Mark Inboden) #7

so firewalls turned off both PC’s rebooted and here is teh audion sources on the remote PC

Let the refresh run: (but I have tried refresh both on the core and remote PC’s as well as my Iphones and Ipads and it has never completed once since I have installed Roon on any device) I really do not know what it does. I will let it run for an 1/2 an hour

And after a 1/2 an our refresh does not complete and I have the exact same results after exiting refresh. (again a refresh has never completed whenever I have tries it over the last few months )

this is really frustrating.

(Scott G) #8

One last try from me, then the Roon Support folks will have to take over…
How is your Network Profile set on your remote PC? Is this set to Public or Private? If it’s set to Public you should try setting it to Private.

(Mark Inboden) #9

Thanks Scott really appreciate the help. Hate to ask but do the roon support folks monitor this? Or is there another way I need to contact them?

(Scott G) #10

Yes they do. If you post in the Support category, they monitor it. If you post elsewhere someone will see it eventually. You’re in the right place. People will use the @support tag to add further attention, but it’s unnecessary.
The support guys are the trauma surgeons. People like me are just good Samaritans with gauze.
They’ll get you going. Sorry you have to go through the frustration.

1 Like
(Mark Inboden) #11

Thanks again Scott I am on a private network both the Core and remote PC

(Daniel Beyer) #12

Realtek drivers can be problematic. Plenty of posts on this thread about the issues they cause.

For local music I always use the generic HD Audio drivers from Microsoft instead, unless there is a gaming reason you need to keep the Realtek drivers on your system.

If so, you might try downloading the very latest drivers from Realtek and install them,
https://www.realtek.com/en/downloads

1 Like
(Dylan Caudill) #14

Hi @Mark_Inboden,

As Daniel suggested above, can you confirm that you’ve downloaded the latest drivers from Realtek and, if so, is there any change here?

(Mark Inboden) #15

Gaming is the reason for the realtek . I have the latest driver installed from ASUS. I just reinstalled them to be sure I had the latest.

Thanks for the download site. But I cannot determine which chipset is on the ASUS MB. Here are the Specs for the ASUS ROG Rampoage VI Extreme MB.

And here is the downloads for the Realtek website (I am not sure which chip it is)

I am trying to determine which of these are the correct SW

(Mark Inboden) #16

Can Roon support help here ?

(Mark Inboden) #17

Sorry Dylan I just saw your roon support. I have the latest drivers from ASUS I cannot determine which if any can be downloaded from Realtek as i cannot find any information other than realtek codec s1220 is used. But I cannot correlate which driver package that would be from realtek (and they advise using the MB manufacturers package.

(Mark Inboden) #18

and all web references to that codec appear to lead back to ASUS for drivers so i have the latest and greatest no change Roon still sees no audio output devices on my PC

(Daniel Beyer) #19

Well, it might help if we stepped back and reviewed how the remote roon client PC’s audio devices are discovered. The Roon server queries the remote machine, if these queries are not responded to then no audio devices are created. So something is blocking the discovery queries from the RoonServer to your remote PC.

The most basic culprit is firewalls and Anti-virus. And the quick way to test that is to just turn it off and see if they appear. If they are not the issue, then something else in your network maybe interfering in this process.

Other things to investigate would be if you have any managed switches or routers in the network mix or anything that restricts or blocks multicast. I also noticed that that motherboard uses Asus’ Languard and something in the optimization software might be interfering.

(Dylan Caudill) #20

Hi @Mark_Inboden,

Thanks for the info here. Moving forward, I’d like to propose a test which should give us a little more information here. Since this is a remote device, there are two places where things could be failing here:

  1. The Core’s communication with the remote
  2. The remote’s communication with the audio devices

With this in mind, can you try temporarily using this remote device as your Core machine? When doing so are you able to discover these devices like normal or do they still not appear?

1 Like
(Mark Inboden) #21

Hi Dan, I turned off all protection by disabling kaspersky completely on both the core the core and remote PC and verified windows protection was off as well. I do not think it is a network problem as Roon is working perfectly on my ipad and my trinnov al16. But I am not a networking expert. I am not familiar with ASUS languard i will look into it. My switches are passive and the I need to look at the arraknis router but I think if it was prohibiting muticast I would not be able to use my Iphones, ipads or my Trinnov with Roon (I think)