Cannot get roon remote to run on a win 10 PC

(Mark Inboden) #22

Hi Dylan,

I assume I just disconnect the core? And make the now remote machine the core ? I assume I can switch it back when I am done with no impact? Or do I need to do something specific like backup the core and restore when I am done on the original machine .

(Mark Inboden) #23

Also can someone explain the purpose of the refresh? I have tried this on all my machines and it just brings up the “refreshing” message and has never completed on any machine i have tried it on.

(Dylan Caudill) #24

Hi @Mark_Inboden,

Yes, you just need to go to Settings | General and Disconnect from the current Core. You can this choose This PC as the current Core.

Correct, you can switch between Cores at will without any issues.

#25

Sorry for partially hijacking the thread but since I’ve also been fighting with Roon network problems plenty myself, I have one question about Realtek network card drivers (Relatek GBe family contoller aka the integrated ethernet connection of Asus Z370-P motherboard).

Do you have recommended advanced settings for the network card used to connect core PC to router and streamer?

What I mean is Windows 10 Device Manager -> Network adapters -> Realtek PCIe GBe Network Family Controller and under there the Advanced tab. Are there any options there which should be changed for optimal operation with Roon and RoonServer running on the computer? Or should these be left untouched/default settings?

My Roon sometimes seems to lose connection and I get buffer underruns because of that.

Thank you

(Mark Inboden) #26

Thanks Dylan, I was not sure if it was that easy. I will be on a business trip through Wednesday evening. I will try this on Thursday once I return and let you know if I then see the realtek as an audio source.

1 Like
(Mark Inboden) #27

Hi Dylan I got back and finally had a chance to disconnect my core on my music server and then set up a core on the PC with the realtek audio devices. Here are the results:

This is the PC with the realtek set up as the core:

And still no local audio devices and Roon still finds all my networked devices:

The weird thing is it is not finding any audio device on this PC I have a Gsync monitor and the audio driver for the monitor is an Nvidia driver. That is the same driver that works on the server PC.

I appreciate the assistance!

(Dylan Caudill) #28

Hi @Mark_Inboden,

Thanks for confirming this. The most common reason for this type of behavior is a firewall is blocking the connection. Can you confirm that Windows Defender Firewall, as well as any antivirus or other firewall software, is completely shut off and then try again?

(Mark Inboden) #29

all firewalls and virus protection turned off re-booted the PC and re verified all of the AV and firewalls were turned off Windows and Kaspersky and still not finding any audio devices on my PC

(Dylan Caudill) #30

Thanks for giving that a try, @Mark_Inboden.

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

(Daniel Beyer) #31

Not related but, I would disable or give a name to those zones.

(Mark Inboden) #32

Thanks Dylan I re-enabled my core on my music server yesterday. Did you want the core running on the PC with the Realtek Drivers ??

(Dylan Caudill) #33

Hi @Mark_Inboden,

I’ve enabled diagnostics on both, and either should work. Can you verify the name of the PC that is experiencing this issue so that I can verify we are checking the correct Windows machine?

(Mark Inboden) #34

The PC Name with the realtek and Nvidia drivers that are not being found is MARKS-7920

(Dylan Caudill) #35

Thanks, @Mark_Inboden.

The diagnostics report has reached our servers and I’ve passed it along to the team for analysis. I’ll be sure to let you know once I receive their feedback .

(Mark Inboden) #36

Thanks Dylan!

(Dylan Caudill) #37

Hi @Mark_Inboden,

Can you please try the following:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Stop Roon on the PC experiencing this issue
  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder
(Mark Inboden) #38

Hi Dylan , On the PC experiencing the problems (Remote) or the server (the Core) or both?

(Mark Inboden) #39

Never mind, I see from the link it is the Core

(Mark Inboden) #40

Ok I have started the Core and it has generated a new RAATServer file

(Dylan Caudill) #41

Hi @Mark_Inboden,

On the PC experiencing the problem. Any change after doing so?