Cannot get Roon to play through to Roon Bridge on my Mac [SOLVED]

Hi @support,

I have recently setup Roon Core on my Synology NAS as a temporary solution until my sT i7 gets here.

My setup:
Roon Core on NAS (connected via 2 bonded 1Gb connections to a simple switch; note that memory and CPU usage is very low throughout the entire Roon usage)
Network is all wired Gb throughout the house, with some Airport Extreme’s serving Wifi duty.
Endpoints include:

  • BeoPlay A9 with AirPlay support (over ethernet)
  • AppleTV (over ethernet)
  • MacBook Pro (OS X 10.11.6, 16GB memory, 1TB SSD, quad-core 2.3Ghz i7 (circa 2011), connected with 1Gb ethernet (priority) + Wifi). Includes three Zones:
    — System Output (tried with internal speakers selected as well as the Oppo)
    — Built-in Output
    — Oppo HA-2 SE (to headphones) [Note that playing music directly from the Mac via iTunes does play through the Oppo]
    Roon Remote on iPad & iPhone
    Music library currently consists of just around 30 or so sample tracks in every format and resolution for testing purposes.

Although I don’t have problems playing any format and resolution of music to either of the AirPlay zones, I cannot get any of the zones on the Mac to play. The error message after about three seconds of clicking play is “An audio file is loading slowly…”, regardless of the audio file format and resolution. No audio is output.

I have tried:

  • disabling the firewall on the Mac
  • reinstalling Roon Bridge (i.e. deleting the application and downloading a new copy and dragging into Applications)
  • restarting the Mac
  • creating and using a new user account on the Mac
  • adjusting all available settings in the Audio Setup
  • connecting the Mac directly into the same network switch that the NAS/Core is plugged into


  • I may have installed Roon Server on this Mac over a year ago as a trial, but I cannot figure out if there is an uninstall procedure and if that might be interfering (how can I verify this?)
  • I do have the HQPlayer trial installed on the Mac but the application is off and I have not changed any of it’s default settings – could that interfere in any way?

The versions of Roon are all the latest available.

Any ideas on how to resolve this issue?


I have had bad experience when Ethernet and Wifi is turned on simultaneously. (Not just for Roon…). Please check if the problem persists if you turn off Wifi and only use Ethernet.

In addition to that: Did you setup your storage as local folders on the Synology Core?

Storage is setup as local folders on the NAS.

I’ll try disabling the Wifi… no luck. Exact same outcome.

I still assume it is something network related.
You have your Synology connected by 2 wires to a simple switch. Does it have 2 IP addresses as well or is some LinkAggregation mode active?
To simplify your current setup, can you remove 1 of the ethernet cables and test if this makes any difference? (Keep your Wifi on your Mac turned off, too).

Have you turned on Jumbo frames? If so, please disable them as well on your Mac and Synology.

You were right – Jumbo Frames was enabled on the NAS. After deactivating it, and leaving everything else as-is, I am able to play bit-perfect music (all formats and resolutions) through to the Oppo on the Mac — even over wifi.

Thank you for your quick and precise help!

You are welcome. Your setup description was very helpful to track this down. :+1: